P0712 Transmission Temp Sensor - where?

Joined
Jan 13, 2019
Messages
19
Location
MASS
I started up my gx470, vsc off light + check engine light soon came on. Code is P0712. I can find little information on where this sensor is located. No information on parts numbers nor images. I was able to find an fj cruiser A750F transmission diagram. Inspecting my own, it seems the #1 ATF temp sensor is internal behind the oil pan and filter, is there is no harness where it is labeled externally. With that said, not sure where to begin in fixing this issue as I can find no replacement part.

1.png
 
Last edited:
Joined
Jan 13, 2019
Messages
19
Location
MASS
I was able to locate the transmission wiring harness and remove it, I found water had entered here and there was corrosion. Can find multiple sources that this is a "problem" with this connector. Will be replacing the external harness with a kit.
 
Joined
Jan 13, 2019
Messages
19
Location
MASS
Can you clean the corrosion and reinstall?
In my case I believe I can. I am going to be cleaning the internal harness pins after dropping the pan and will attempt to salvage the female external harness at the same time, depending on what type of corrosion I find inside the female adaptor. Both harnesses with pigtails can be sourced for under 100$ each. What's interesting is the rubber gasket is intact so I ponder why many people have an issue with this same plug. It is a very tight connection with a hinge lock and there was still water inside. It rained heavily the day prior and I drove through some large puddles - even so, I wonder if water is coming down vertically into each individual terminal.
 
Top Bottom