OME suspension CLUNK (1 Viewer)

Joined
Jun 13, 2008
Messages
234
Location
Price Utah
I've got the clunks. When I round a corner the new OME heavy suspension is clunking in the rear. I used the OME bushings and shackles. What is the remedy for the clunks. I havent retorqued since install, could that be the issue?
 

mwalls54

Cruiser Nutjob
SILVER Star
Joined
Dec 4, 2003
Messages
2,525
Location
Roanoke, VA
 
 
 
did you use greasable shackles? Mine did the same new. i put a few squirts of grease in mine a couple of times and once the suspension settled it went away. It lasted a week or 2 and about 200 miles
 
Joined
Jun 13, 2008
Messages
234
Location
Price Utah
did you use greasable shackles? Mine did the same new. i put a few squirts of grease in mine a couple of times and once the suspension settled it went away. It lasted a week or 2 and about 200 miles
Yes I did get the greasable shackles. I'll squirt some grease in and see if that helps. I've only put about 150 miles on the suspension, so maybe it needs a few more miles to get settled.
 
Joined
Jan 9, 2004
Messages
1,597
 
 
 
Did you hook up your factory sway bars? Mine have clunked for years .I just don't pay attention anymore .
 

esh

SILVER Star
Joined
Apr 22, 2003
Messages
2,054
Location
Oregon
 
 
 
Are the teflon pads between the leafs nice and greased?
 
Joined
Oct 1, 2005
Messages
2,818
Location
Colorado
I've posted this before and will again. I cured the popping by changing the greasable bolts to the slotted style from the OME style and it's been quiet ever since.
 

esh

SILVER Star
Joined
Apr 22, 2003
Messages
2,054
Location
Oregon
 
 
 
You said you've retorqued your ubolts, but keep an eye on that as well.

Front Range's solution might be worth a look. Where can the slotted pins be found?
 

RockDoc

I'll take Bruce Vilanch for the block.
Joined
Jun 3, 2007
Messages
7,086
Location
SW Manitoba
 
 
Out of curiosity, have you checked to make sure the sleeve inserts in the spring eyes aren't sliding?
 
Joined
Sep 9, 2007
Messages
469
Location
Vegas Baby !
 
 
I just put im CS005's Plus 1 DXL2 Leaf in the back and now I have the Knunks too... I'll try to grease everyhing up and post a pic.


Mark
 

RockDoc

I'll take Bruce Vilanch for the block.
Joined
Jun 3, 2007
Messages
7,086
Location
SW Manitoba
 
 
How do I check to see if there sliding is it visible without pulling the spring off?
You should be able to see that the spring eye is not centered in the shackle or hanger. Might not be easy to see with fresh bushings though, my cheapo bushing were worn to &$%$ making it easy to see.

Rock Doc did you end up putting the sleaves in a vice to make them stop shifting?
I think I tried to squish them a bit, but but they are tough and I didn't have a vice, so that didn't work. I ended up cleaning and roughing up both surfaces (outside sleeve and inside spring eye) and epoxying them in place. By the time I got around to fixing it, the inserts could easily be removed and inserted by hand. So far it's holding up. :)
 
Joined
Oct 1, 2005
Messages
2,818
Location
Colorado
Just the bolts Steve. The OME have a small hole to grease the bushing, 4+ is slotted and greases the entire length. I had the clunking, popping, noisy springs and once I replaced the bolts all noise vanished.

I met another 60 owner the other day and he really liked my sunroof so I gave him your name.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom