OEM brake pads.. (1 Viewer)

Joined
Jan 16, 2007
Messages
94
Location
Berkshires
Just pulled old pads...yikes...rotors are good though, got new OEM pads. The old pads however had no shims or anti squeal plating at all, is this normal? Also got anti sqeel treatment spay for the backs of new pads and is the same green color as the back of the new TEQ's do they come treated already?
Thanks
B
 
Joined
Nov 16, 2003
Messages
6,045
Location
Dixie co. Florida
the 80 originally came with shims, if yours are missing you have to purchase them separately if you want them.

I run 100 series front pads (very long life) shims don't fit when the pads are new ad thick so I never have bothered to install them, sometimes get light squeaks on the first stop, other than that no problem.
 
Joined
Jan 16, 2007
Messages
94
Location
Berkshires
I put them back together w/out as I didnt have any and had no way to go get some. Did a shake down and they seem fine. Man OEM is the way to go. Mine from the dealer were TEQ's I dont know if that is common or not? I may add shims as they wear we'll see.
 
Joined
Apr 7, 2004
Messages
1,269
Location
Reno, NV
the 80 originally came with shims, if yours are missing you have to purchase them separately if you want them.

I run 100 series front pads (very long life) shims don't fit when the pads are new ad thick so I never have bothered to install them, sometimes get light squeaks on the first stop, other than that no problem.

I've never really understood how they help? What is causing the squeal? and how are they preventing it? I don't use them with 100 series pads and all is good.
 
Joined
May 1, 2006
Messages
856
I put them back together w/out as I didnt have any and had no way to go get some. Did a shake down and they seem fine. Man OEM is the way to go. Mine from the dealer were TEQ's I dont know if that is common or not? I may add shims as they wear we'll see.

Mine shook down and caused my inside passenger pad to wear down and scrape my rotor while the outside pad looked fine.
 
Joined
Jan 16, 2007
Messages
94
Location
Berkshires
roger that I'll get them in the a.m. and put them in asap...thanks Capo..
 
Joined
May 1, 2006
Messages
856
Ya it was weird. But now I just got them and havent had them on for long enough to check wear on the new pads.
 
Joined
Nov 16, 2003
Messages
6,045
Location
Dixie co. Florida
Mine from the dealer were TEQ's I dont know if that is common or not?


TEQ = Toyota in Japanese approximated to European letters


If you have Asian characters installed on your computer it looks like this

トヨタ
 
Last edited:
Joined
Nov 1, 2004
Messages
364
Location
Portland, OR
does it matter what year 100 series pads you get for your 80?? BTW I have a '97 LX :confused:

barrypt5
 

cruiserdan

SupportingVendor Emeritus
Moderator
Joined
Mar 27, 2003
Messages
25,434
Location
Land Cruiser Heritage Museum broom closet

NorCalDoug

problems solved daily...
Joined
Oct 27, 2003
Messages
6,217
Location
uhhhh...duh...Northern CA
just get yer pads from CDan...then you don't have to remember what year ;)
 

Users who are viewing this thread

Top Bottom