OEM brake pads..

Joined
Jan 16, 2007
Messages
94
Location
Berkshires
Just pulled old pads...yikes...rotors are good though, got new OEM pads. The old pads however had no shims or anti squeal plating at all, is this normal? Also got anti sqeel treatment spay for the backs of new pads and is the same green color as the back of the new TEQ's do they come treated already?
Thanks
B
 
Joined
Nov 16, 2003
Messages
6,045
Location
Dixie co. Florida
the 80 originally came with shims, if yours are missing you have to purchase them separately if you want them.

I run 100 series front pads (very long life) shims don't fit when the pads are new ad thick so I never have bothered to install them, sometimes get light squeaks on the first stop, other than that no problem.
 
Joined
Jan 16, 2007
Messages
94
Location
Berkshires
I put them back together w/out as I didnt have any and had no way to go get some. Did a shake down and they seem fine. Man OEM is the way to go. Mine from the dealer were TEQ's I dont know if that is common or not? I may add shims as they wear we'll see.
 
Joined
Apr 7, 2004
Messages
1,257
Location
Reno, NV
the 80 originally came with shims, if yours are missing you have to purchase them separately if you want them.

I run 100 series front pads (very long life) shims don't fit when the pads are new ad thick so I never have bothered to install them, sometimes get light squeaks on the first stop, other than that no problem.

I've never really understood how they help? What is causing the squeal? and how are they preventing it? I don't use them with 100 series pads and all is good.
 
Joined
May 1, 2006
Messages
856
I put them back together w/out as I didnt have any and had no way to go get some. Did a shake down and they seem fine. Man OEM is the way to go. Mine from the dealer were TEQ's I dont know if that is common or not? I may add shims as they wear we'll see.

Mine shook down and caused my inside passenger pad to wear down and scrape my rotor while the outside pad looked fine.
 
Joined
May 1, 2006
Messages
856
Ya it was weird. But now I just got them and havent had them on for long enough to check wear on the new pads.
 
Joined
Apr 27, 2003
Messages
9,936
Location
Salt Lake City
I just did the 100 series pads last night. VERY tight fit, but they have a ton of brake material on them. Shims didn't fit, I'll put them back in once the pads have worn down, which looks like it may be awhile.
 
Joined
Apr 27, 2003
Messages
9,936
Location
Salt Lake City
When I ordered mine I just said "100 series pads", they didn't ask for a year differentiation. CDan would be able to tell you if there's different pads.
 

Users who are viewing this thread

Top Bottom