My slow '78 Mustard Yellow build (1 Viewer)

Joined
Dec 27, 2006
Messages
189
Location
North Of Dallas
I've been driving it again for about 2 weeks. I got the fj80 power steering installed and got the Hydraulic winch installed. I didn't take any pics of the progress, I kept forgetting the camera.

THe 1KZ-TE has an idle up feature which has been nice the last few mornings. Just push a button and it idles up to about 1500 RPM. I suppose all the other toyota diesels have this too. Its also nice to keep the vibrations down when waiting at a traffic light.

I still have lots to do including the exhaust and the front drive shaft. I built a little LED panel so I can see the status of the check engine light, idle up switch, and the Glow Plugs. That will get installed when it warms up a little bit here.
 
Joined
Oct 19, 2008
Messages
233
Location
Denver/Boulder
Wow, you make a difficult conversion look and sound so easy. That pic with the 1kz in the engine bay makes it look like like such a small engine; it takes up most of the space in my Tacoma.

Have any pictures of how it currently sits?
 
Joined
Dec 27, 2006
Messages
189
Location
North Of Dallas
Not much has changed in the engine bay I don't think. Is there anything in particular you want to see?

Here are a few of the installed FJ80 PS box and my homemade upper shock mount. The fluid all over the box is from the ps fluid return line that gave up during one of our 100 degree days.
ps1.jpg
ps2.jpg
ps3.jpg
 
Joined
Dec 27, 2006
Messages
189
Location
North Of Dallas
What do you want to know? Install specifics? How it drives? I'm happy to answer any questions you might have.

Here are some pics I neglected to post from long ago.
back.jpg
assembled2.jpg
assembled1.jpg
 
Joined
Dec 27, 2006
Messages
189
Location
North Of Dallas
Update

Time for an update!

Here is what I have done lately:
full turbo back 3" exhaust, Front mount I/C, Welded up a front driveshaft so its 4wd again! And a Techtom Rom Tune. I'm still playing around with the tuning but its already picked up quite a bit of power over stock. Here is the before and after dyno:
OEM%252520VS%252520sorta%252520tuned.jpg


Red is the "tuned" file, Blue is the Factory file. I should be able to bring up the dip at 2500 and fix the dip right before 3750.

I'm a little unsure how much further to push the fuel and timing. EGT's get up near 1200 if I really flog it in the upper RPM's. Boost is 20psi.

I bought a Japanese tuned ECU and I'm still reverse engineering it. I still haven't found out what all the maps do. I have found the main fuel map, main timing map, boost injection timing retard and the TPS "sensitivity" map.

Its ALOT more fun to drive now!
 
Joined
Dec 27, 2006
Messages
189
Location
North Of Dallas
8 Years!!!! Time for an update I suppose!

Lets see, what has happened?

I swapped over to the manual 1KZ-TE ECU about a year ago and had some trouble with it making power for quite a while. It turns out that I was misreading the schematic for the 1st gear power limit circuit. It is designed to limit torque in first gear to keep from spinning the tires I guess. I definitely don't want that! The manual ECU is a little smaller and fits behind the instrument cluster better. I also replaced all of the electrolytic caps at the same time.

I rebuilt the rear axle due to some rumbling noises at about 45mph. I decided to go with 4.56 gears too at the same time to get my revs up at highway speeds. I'm probably going to go with 33" tires as well instead of the now worn out 34's.
20190622_093329.jpg

20190608_204639.jpg


Then I had to rebuild the front axle too since I did the gear change.
20191019_153416.jpg

20191026_150448.jpg
 
Joined
Dec 27, 2006
Messages
189
Location
North Of Dallas
I went for a spin a few days ago and discovered my boost was well over 22 psi! I popped the hood and found the boost source line had come off of the turbo. No boost control at all! I have been using a mechanical bleed to control the boost. I was digging around in my parts bin looking for a new hose and found an old Greddy electronic boost controller. So I decided to install it. Unfortunately it would not raise the boost above the Westgate setting. I tracked the problem to the boost controller. Woth the help of The Creature I was able to trace the output of the internal processor to the output transistors for the solenoid. The base of the transistor was getting the signal but there was no change in output.
20200620_160303.jpg
20200621_120318.jpg

Since I'm cheap and didn't want to wait for Mouser to deliver a new transistor, I went back to the parts bin. I have an old dead MR2 ECU that still had the injectors drivers. After comparing the datasheets I decided to try one of them. It worked well and now my boost is back under control!
 
Joined
Dec 27, 2006
Messages
189
Location
North Of Dallas
Awesome build! I'm struggling through 1KZ-TE ownership in the US right now. Do you know of anyone in the US that can repair 1KZ ECUs?
Not specifically, Is it damaged from leaking capacitors? I'd be willing to try. I still have an auto ecu on the shelf i'm no longer using.
 

Users who are viewing this thread

Top Bottom