Metallic screeching when turning left only

liv2bike

SILVER Star
Joined
Jul 3, 2013
Messages
282
Location
Idaho Falls
Hey guys. Over the last couple of days I’ve noticed a metallic screeching coming from the passenger front wheel/wheel area only when turning left at speeds >25’ish mph. Doesn’t matter if breaks are being applied. Does it under breaking and when not breaking. And it’s only when the steering wheel is turned past the 10’oclock position. It does not screech/squeal when going straight or when turning right.

I’ve been underneath it a few times. Everything looks normal. Nothing appears to be out of place or loose. Heat shield looks fine. I don’t see any debris or rocks. No leaking fluids.

Looking for some input bc a bunch of y’all have way more knowledge than I do. I did a search and not much of anything came up. Haven’t made any kind of mods either. Truck has around 130k miles. So I’m coming up empty. And here in Idaho Falls my only real option is Teton Toyota. And I’m afraid they’ll just want to throw parts at it. Thanks in advance. Appreciate any input. Cheers.

Guy
 

liv2bike

SILVER Star
Joined
Jul 3, 2013
Messages
282
Location
Idaho Falls
If I only had a lift...or access to one. But I don’t. But something I’m going to speak to Toyota about. No good indy here in Idaho Falls.
 

liv2bike

SILVER Star
Joined
Jul 3, 2013
Messages
282
Location
Idaho Falls
And one more observation. It’s not a deep grinding noise. It’s a high pitched screech. Not heavy but a light metallic screech. If that makes sense.
 

bloc

SILVER Star
Joined
Sep 19, 2008
Messages
7,830
Location
Central Texas
Front hub and rear axle bearings wearing out aren’t unheard of at your mileage. I’d get each corner in the air and see if there is any play in any of the wheel/axle assemblies.
 
Joined
Jan 23, 2019
Messages
1,414
Location
Florida
I would take the wheel off and look for shiny metal. Brake dust cover loose; or inside the actual wheel anything like debree there?
 

liv2bike

SILVER Star
Joined
Jul 3, 2013
Messages
282
Location
Idaho Falls
Thanks guys. I’ll do some more investigating later today. Hoping it’s the brake dust cover as mentioned. Thanks.

Guy
 

Users who are viewing this thread

Top Bottom