LED polarity diagram for the instrument cluster (1 Viewer)

John Young

SILVER Star
Joined
Dec 4, 2015
Messages
759
Location
Dubai, UAE
I seem to have LED's on the brain lately. Especially after I found more than 5 bulbs burnt out in the instrument cluster of our 1993 Middle East 80. I've been replacing LEDs and putting new LED lights everywhere it seems. Laugh if you like, but I can actually see things down in the corners, like the fuel pump relay.
1602789465635.png


Anyways, I have the dash apart again for ... reasons. I bought all the necessary LED's to replace everything in the dash. Unfortunately, the available LEDs are polarity sensitive and neither the instrument cluster nor the panel switches are marked--because they did not have to be with the incandescent bulbs from the factory.

I have read all the threads I can find in the Model 80 forum and while there is mention after mention of the polarity issue, I cannot for the life of me find where anyone has posted a polarity map for the instrument cluster or the panel switches. I'm hoping I've just missed it. Does anyone know if such a map exists?

My next step is to resort to the wiring diagram which makes my eyes hurt just thinking about.
 

ProjectsNMotion

SILVER Star
Joined
Sep 19, 2018
Messages
239
Location
New York
I recently swapped (almost) all of the bulbs in my gauge cluster with LEDs. I skipped the low fuel warning light because it's supposed to vary in brightness and an LED simply won't do that in that circuit.

The way I went about it was installing each LED and then applying 12V power, from a bench top power supply, to the correct terminations where the chassis harness connectors plug in. I referenced the wiring diagrams for the terminal numbers and polarity. It really didn't take very long doing it this way. 15 minutes I think?

Cheers
 

John Young

SILVER Star
Joined
Dec 4, 2015
Messages
759
Location
Dubai, UAE
It took me a lot longer...
Here is my results:
FZJ80 instrument cluster LED map 1.jpeg

LED instrument map 2.jpeg

instrument cluster LED map 3.jpeg

instrument cluster LED map 4.jpeg


The only one I could not figure out was the A/TP light. Apparently it is not working on my truck. I put the transfer case in neutral and my understanding is that it is supposed to light up. It did not. So I left that one as incandescent.

I was a little apprehensive about applying voltage to my cluster to test. I did it by a combination of tracing and trial and error, plugging it into the dash to check whether the lights would come on when I turned on the ignition but did not start the car.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom