Kazuma Supercharger Recommendation

Joined
Jul 13, 2016
Messages
369
Location
Georgian Bay Ontario
Visit site
Looking for opinions on this. My 97 80 has I believe a G1 version Kazuma supercharger on it. Over the winter I fully went all out on rebuilding the top end of my 1FZ-FE, new hoses/parts everywhere, new head, new valves, blah blah blah, hours upon hours of cleaning... When I parked the truck the supercharger worked well, I could easily pass on the highway and the power increase from any other 1fz 80s I've driven was quite noticeable. Now while driving it seems to lag, not sure if it's transmission or loss of power from a failing SC. Also notice that there is a significant increase in SC whine noise while stomping on the throttle, enough to hear from in the cab with some music on whereas before I could never hear the SC whine. There is also a fast-paced ticking around 1800-2500RPM while driving, not sure if it is engine pinging or again another noise from the SC failing. I contacted Jon Bond and he is 3 weeks out on starting rebuilds and then another week to rebuild it plus time to ship it back across the border/customs. This is my daily driver and it would be a massive pain in my rear if it was down for a month plus, especially as I'm on contract for another 4 months of constant out of town work and I live out of my truck when I'm out of town on work. Wondering what people's opinions are if my SC is indeed failing and needs to be sent out or if I'm just working myself up over some other issue.

Some additional info:
- When inspecting the supercharger while I had it apart over the winter months there was some small chipping on the rotors but otherwise, they spun very freely and smoothly. There was also no lateral movement on the snout drive.
Unknown.png


- I installed 2JZ injectors I got from Rick, could the ECU be miss fueling / not learned the new injectors?
IMG_3190.JPG

- When changing the oil in the snout a week or so ago the old fluid was quite clean still. Replaced with new GM supercharger oil
IMG_6671.JPG


- the old PCV routing was like this with a lot of oil going through the SC. I changed that with an inline catch can now (inline on green line)
Supercharger Vacuum Rerouted.jpg


Appreciate any help or info people have for me, Thanks
 
Joined
Jul 13, 2016
Messages
369
Location
Georgian Bay Ontario
Visit site
Rick, checked over all that and everything appears to be all good.

I think I did find the source of my fast-paced ticking around 1800-2500RPM while driving noise though. Appers to have been one of my SC belt pulleys bearing gone bad. Lucky for me amazon.ca had the gates replacements on prime so I was able to order both the tensioner side and static side replacements. No more ticking noise and the supercharger appears to be functioning fine...

Also spun the charger with the belt off and there seems to be little to no backlash (left-right pully turn) nor play front to aft and no alarming noises when spinning freely.
 
Joined
Jul 13, 2016
Messages
369
Location
Georgian Bay Ontario
Visit site
Power seems sufficient. lots of good pull 2nd gear. I think it's my trans causing my lag issues, played around with the PWR button and seems to work much better. Maybe time for new shift solenoids...
 

Users who are viewing this thread

Top Bottom