Interesting Break (1 Viewer)

Vlad

The Impaler
Moderator
SILVER Star
Joined
Feb 7, 2002
Messages
11,116
Location
Woodstock, GA
I found I had a bit of a wobble. Tires balanced, alignment is perfect, etc.

So I went hunting.

Guess what? Part #52392A (Diff support arm) is cracked clean in half! It has enough pressure on it to keep it in place, but it is allowing the diff to move and causing the vibration.

I was wondering why I saw a rub spot on the diff near the pinion and had loading/unloading noises as well as a vibration no matter what I did.

Go figure. Looks like I get to wrench a bit. Probably a good time to find it. The inner clamp on my PS CV let go too, probably because of the same problem.
 

Vlad

The Impaler
Moderator
SILVER Star
Joined
Feb 7, 2002
Messages
11,116
Location
Woodstock, GA

How about them apples.

New one has a lot more heft and was clearly redesigned.
 

Vlad

The Impaler
Moderator
SILVER Star
Joined
Feb 7, 2002
Messages
11,116
Location
Woodstock, GA
I think it was a wear item. It was original from 2003 and there were several TSBs for vibrations, etc that recommended replacing this arm. I took that and had a look and saw the break. The sides of the break had wear where it had been popping along all this time.
 

Vlad

The Impaler
Moderator
SILVER Star
Joined
Feb 7, 2002
Messages
11,116
Location
Woodstock, GA
Yeah, I would recommend everyone take a peak, very easy fix and can cause some really confusing symptoms (vibrations) that can lead to balancing tires and alignment when it is not needed.
 

Vlad

The Impaler
Moderator
SILVER Star
Joined
Feb 7, 2002
Messages
11,116
Location
Woodstock, GA
Swapped out my PS CV as the boots were torn from having too much play due to this break. Can't stress enough the need to check your diff supports!
 

Users who are viewing this thread

Top Bottom