cluster removal??

Joined
Sep 18, 2022
Messages
39
Location
vernon bc canada
my dash is sooooo dim, i must have only 1 light working, how does the cluster come out? i removed the 2 screws and tried lifting up and out, but seems like something is stopping it from the bottom, the top seems to come out some but not enough to get at the plugs etc, is there a trick to removing the cluster?
 
Joined
Jan 19, 2021
Messages
123
Location
Emigrant, MT 59027
my dash is sooooo dim, i must have only 1 light working, how does the cluster come out? i removed the 2 screws and tried lifting up and out, but seems like something is stopping it from the bottom, the top seems to come out some but not enough to get at the plugs etc, is there a trick to removing the cluster?
just a couple of tabs on the bottom to hold it in. Lift from top and work it out lifting upwards and out. MAKE SURE YOU DISCONNECT THE BATTERY
 

pb4ugo

SILVER Star
Joined
May 8, 2006
Messages
3,050
Location
spay-lay-wi-theepi, Ohio
The top needs to fold towards you, but you need to figure out how to disconnect the speedo. The top needs to fold forward enuff to clear the 2 bottom tabs and lift out. . Once out you might consider shortening the 2 lower tabs so it comes out a little easier in the future. Be sure to disconnect the batt. The contacts to the amp gauge can ground out.
 
Joined
May 9, 2021
Messages
903
Location
Texas Coast
Also, I recommend tracing your spedo cable and getting whatever slack you possibly can pushed up behind the cluster. You should have just enough slack to reach your hand behind the cluster and undo the connection to the back of the cluster. Once the spedo cable is free you should be able to lift the cluster enough to clear the tabs.
 

TLCJC

SILVER Star
Joined
Sep 30, 2012
Messages
613
Location
Virginia
Tons of threads on this if you use the search box
 

JVZii

SILVER Star
Joined
Jul 5, 2016
Messages
643
Location
Atlanta, GA
I will throw in. If you just need to change light bulbs, you can snake your hands up behind the dash.

IMG_20220910_151647__01.jpg


The holders twist in and out. The high beam is right over the column so it's tough to get to. But a little fiddling and it can be done.

If you want to pull it as noted above there are some hooks at the bottom that force you to roll it down from the top. And do DISCONNECT THE BATTERY or you run a risk of burning the board.

IMG_20220717_162724__01__01.jpg


All of these chores are much easier if your hands stopped growing when you were 7.

Jack
 

TheHardWay

Ain't as easy as it looks
SILVER Star
Joined
Dec 29, 2013
Messages
1,747
Location
Las Cruces, NM
I unhook my clutch pedal return spring and reach up from underneath to get the speedo cable off.
Now why did I not think of that?

GENIUS!!
 
Joined
Sep 18, 2022
Messages
39
Location
vernon bc canada
I will throw in. If you just need to change light bulbs, you can snake your hands up behind the dash.

View attachment 3134774

The holders twist in and out. The high beam is right over the column so it's tough to get to. But a little fiddling and it can be done.

If you want to pull it as noted above there are some hooks at the bottom that force you to roll it down from the top. And do DISCONNECT THE BATTERY or you run a risk of burning the board.

View attachment 3134775

All of these chores are much easier if your hands stopped growing when you were 7.

Jack
thanx soooo much for the pics, these really help, its just a few bulbs out, i may try from the back, thanx for the pics
 
Joined
Sep 18, 2022
Messages
39
Location
vernon bc canada
well i followed the inscructions from here and disconected battery and lifted it up and back and got the cable disconected then pulled out, to my surprise most of the lights worked when i wiggled them, i took tthem out and cleaned the board with contact cleaner and repleced the dead one, all seems to work now butttttt when i put it all back and drove her the speedo cable made a clik clik clik noise and the speedo arm was kinda bouncy and not accurate. does the cable conector only go in one way? it seemed to click properly. ill take it apart again today to see why its cliking.
 

firemanj92

SILVER Star
Joined
Mar 11, 2020
Messages
381
Location
SF Bay Area, Ca-NorCal
well i followed the inscructions from here and disconected battery and lifted it up and back and got the cable disconected then pulled out, to my surprise most of the lights worked when i wiggled them, i took tthem out and cleaned the board with contact cleaner and repleced the dead one, all seems to work now butttttt when i put it all back and drove her the speedo cable made a clik clik clik noise and the speedo arm was kinda bouncy and not accurate. does the cable conector only go in one way? it seemed to click properly. ill take it apart again today to see why its cliking.
I have found it is very temperamental. Hopefully, it did not break when it was removed. I find it easier to undo the transfer case end first to give me slack on my early LC. On my early LC, the speedo end is squared and the TC end has a tang on it so maybe it was just pulled out too far... 🤞
 

Users who are viewing this thread

Top Bottom