Builds Big Green Buffalo Build Thread (2 Viewers)

Joined
Jan 31, 2019
Messages
586
Location
Atlanta
Now…




557B03B4-624A-4A60-8062-7424A9592195.jpeg
64463DF9-6F47-42E7-B1C9-C4E7F2109BD7.jpeg
E5C8B4E9-8300-4EFD-8D00-4BBEC4A8E8FB.jpeg











--------------------------------------------------------------------------


Howdy fellas, Ryan here. Ive been into Toyotas for a long time, i finally got me an 80, my first land cruiser. i bought this truck Feb 2nd 2019. I paid a reasonable price for it, drove it 65 miles to the shop, and pulled the engine out. 287k.... i know these trucks pretty well so i dove in deep right away. its a 1995 incase anyone is wondering. the name came quickly to this truck, on the one and only drive ive had in it so far, i could try to explain it but it wouldnt make sense, but its green so you get that much, im sure. im not much into forums, so this will probably be a pic heavy "build thread"

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr
 
Last edited:
Joined
Jan 31, 2019
Messages
586
Location
Atlanta
Last edited:
Joined
Jan 31, 2019
Messages
586
Location
Atlanta
Last edited:
Joined
Jan 31, 2019
Messages
586
Location
Atlanta
painting continues

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr


i cleaned up the over flow of white with black nail polish, its not perfect but you have to draw a line somewhere.... for the record all the paint i used is high temp 500F* engine paint. the black is rusto and the silver is duplicolor ceramic. the marker i used for the white is oil based paint and the nail polish is enamel. i cleared everything with ceramic 500F* clear coat, also duplicolor.



Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr
 
Joined
Jan 31, 2019
Messages
586
Location
Atlanta
Last edited:
Joined
Jan 31, 2019
Messages
586
Location
Atlanta
Joined
Nov 9, 2012
Messages
13,472
Location
Olathe, KS, USA
properly torquing the crank bolt, 304 ft lbs.. it was a two man job

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr

Engine is looking great!
Are you a tech at a repair facility?

I am concerned on your procedure on tightening the HB bolt.
You wrapped a chain restraint around the HB pulley and used that to HOLD the engine from rotating while tightening the bolt.

That places HUGE shear on the rubber in the HB between the pulley and the center hub. You are SUPPOSED to either hold by the flex plate in the rear or bolt on a wrench to the CENTER of the HB. Take a look at the tools designed for this. If I find the exact one, I will pass along the link.

You MAY have damaged the rubber cushion between the pulley and the center hub. If this shears, your belts will not turn when the crankshaft spins.
 
Joined
Jan 31, 2019
Messages
586
Location
Atlanta
^^^^ i see what youre saying but ive done this 100 times and i havnet had an issue yet, its not a GM..



got a few more things done today..

i completely cleaned the wiring harness, no more oil or grime on it, cleaned every connector and put dielectric grease in all the connectors. i also taped up every placed where the old tape came apart or broke. it may not show, but this is now a really clean harness.


Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr


i also removed all the evap stuff along with egr. the truck didnt have a catalytic converter when i got it.


Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr
 
Last edited:
Joined
Jan 31, 2019
Messages
586
Location
Atlanta
pressure washed the trans/tcase. didnt get a picture of it clean, and honestly it didnt come out very clean, but i got most of the crusty oily sludge off of it.

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr




GOT THE ENGINE INTO THE TRUCK!! this was pretty exciting!



Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr

Untitled by bill bill, on Flickr




also got the trans/tcase fully installed, put a new trans mount on it too. the original unit was sooo soft front all the oil.

the exhaust is terrible looking, im going to get header(s) for it asap. also, a supercharger.
 

Users who are viewing this thread

Top Bottom