AHC Sensor Adjustment for Lift

hoser

SILVER Star
 
 
Joined
Dec 21, 2003
Messages
9,535
Location
Bay Area, CA
@2006 LX470 What does the suspension do when you press the H setting? Does it attempt H and then come back down to N or does the H light flash and nothing happens?
 
Joined
Feb 5, 2019
Messages
38
Location
Cleveland
@2006 LX470 What does the suspension do when you press the H setting? Does it attempt H and then come back down to N or does the H light flash and nothing happens?
Tries going into H mode, then goes back down to N. I think you are right about it not overpressurizing the system. Hopefully the cable I get tomorrow can read my pressures cause my current cable is not connecting to the ahc ecu in techstream (but it has worked in the past)
 
Joined
Feb 25, 2018
Messages
655
Location
Hungary - EU
Tries going into H mode, then goes back down to N. I think you are right about it not overpressurizing the system. Hopefully the cable I get tomorrow can read my pressures cause my current cable is not connecting to the ahc ecu in techstream (but it has worked in the past)
I had to clear the DTC’s manually (with a paperclip in the obd connector outlined in the FSM) when TS didn’t connect to the AHC ECU - although it was able to read live data (if I clicked that button - not default), but couldn’t read the trouble codes - which can be blinked out by the way (with a paperclip in the obd as per FSM)
 
Joined
Feb 5, 2019
Messages
38
Location
Cleveland
I had to clear the DTC’s manually (with a paperclip in the obd connector outlined in the FSM) when TS didn’t connect to the AHC ECU - although it was able to read live data (if I clicked that button - not default), but couldn’t read the trouble codes - which can be blinked out by the way (with a paperclip in the obd as per FSM)
I cannot get to the live data for the AHC since it will not connect to the ecu. I can view live data for the engine ecu just fine though
 
Joined
Feb 5, 2019
Messages
38
Location
Cleveland
Do you think if the torsion bars are not adjusted to bring the pressures within spec it could prevent it from going into H? The rear seems like it can go up significantly higher than the front without issues. When I hit H, the back goes up, then when the front starts to go up, it reverts back to N and the rear drops back down. Appreciate your insight and thoughts on this
 

hoser

SILVER Star
 
 
Joined
Dec 21, 2003
Messages
9,535
Location
Bay Area, CA
The H mode lifts the rear higher than the front. I do not think it is a pressure spec problem. But like I said, lower the front and see.
 
Joined
Feb 25, 2018
Messages
655
Location
Hungary - EU
I cannot get to the live data for the AHC since it will not connect to the ecu. I can view live data for the engine ecu just fine though
Mine also said it wouldn’t connect to the AHC ECU, but in reality it just couldn’t connect to the trouble codes section. After aknowledging the error message and clicking on data list it however showed the sensor readings.
 

hoser

SILVER Star
 
 
Joined
Dec 21, 2003
Messages
9,535
Location
Bay Area, CA
Well, I'm the OP in this thread (started 14 years ago). My AHC finally had it's first issue...

 
Joined
Feb 19, 2012
Messages
749
I failed to measure beforehand. Installed the rear king springs and adjusted height sensor. Also adjust the front sensors to as short as they would without cutting the rods. Front spec 6.9 mpa and rears are 5.40. All heights work without any issues. Looks to be level at 21.5 inches all around. How much you think the front went up with just off of rod adjustment? Will check again in a day or so on more leveled ground.
 

rvk

Joined
Apr 10, 2019
Messages
7
Location
Greenville, SC
Does anyone have suggestions on rear spring spacers? I've read that I should get 10mm, as I'm not trying to raise the rear - just improve ride quality.

I've already played with t-bars and height sensors and flushed fluid.
Thanks
 
Top Bottom