1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

snowblower

Discussion in 'Workshop and Home Improvement' started by apeterson, Feb 27, 2007.

  1. apeterson

    apeterson SILVER Star

    Messages:
    3,848
    Likes Received:
    176
    Joined:
    Jul 20, 2006
    Location:
    Pequot Lakes MN
    I have a snow blower that seems to die every time it gets snow in the auger... not alot of snow an amount it should be able to handle, almost like it can not get enough gas. I took the carb apart and cleaned it... runs great until it is under a load...

    anyone have ideas?
     
  2. High Desert

    High Desert

    Messages:
    1,227
    Likes Received:
    2
    Joined:
    Mar 21, 2005
    Location:
    Central Oregon
    Check air cleaner, shouldn't be dirty, running in the snow and all..

    get a new plug, I bet that's the problem.

    If it has a fuel filter change/clean it. If it has a fuel cut off valve make sure it is all the way open.

    there is a high speed screw on the carb, if you have a owners manual it will tell you how to adjust this so it will run under a load.

    That about covers it as long as the auger is working properly..

    When my Craftsman 8.5hp was "loading" up it was the plug that was bad.
     
  3. apeterson

    apeterson SILVER Star

    Messages:
    3,848
    Likes Received:
    176
    Joined:
    Jul 20, 2006
    Location:
    Pequot Lakes MN
    Thanks to everyone... I forgot to post I got it running a few days ago... I took the carb off and cleaned it again... then I just adjusted the high speed jets and good as new...

    we are getting a snow storm here the last few days so it could not have come at a better time!!!

    Thanks everyone!!