Rockpals 100W foldable Solar Panel - 64.99 +tax shipped

Joined
Sep 8, 2020
Messages
37
Location
USA
Yeah. Looks like the 40.00 coupon is back but the other coupon is dead. Knew this wasnt going to last long.
 
Joined
Jul 5, 2017
Messages
485
Location
Denver
Got mine yesterday. super fast shipping. I was ecited to try it out, so i drained my jackery down to 33%.
Pe4NLjYiSHeQXF%en2U2Fw.jpg
cl+cXHpQSxmCvtEh5FZynw.jpg

Laying flat, november sun 54W, which is actually better than the 40W i get from ac or car dc charging.
%nDkbkHzTJe3yKMtSLn+Dg.jpg
UfmHlN18TwioTj6QrzXl3Q.jpg

Later under significant overcast still getting 12W which isnt terrible. If needed i think i could run my fridge and keep phones/gps charged indefinitely off this setup. Thanks for hooking up the deal!
 
Joined
Nov 6, 2017
Messages
227
Location
Minneapolis
i got mine as well and tested, worked as advertised. Using this to augment my 100w fixed panel. This is an awesome deal, thanks for sharing!
 

76FJ40

Old Fart
SILVER Star
Joined
Mar 1, 2002
Messages
4,939
Location
NOVA
i got mine as well and tested, worked as advertised. Using this to augment my 100w fixed panel. This is an awesome deal, thanks for sharing!

According to the Q&A on Amazon, these can't be used in parallel or series. How did you connect yours to your fixed panel and did you have any problems.

I'm planning to use 2 of the foldable panels in parallel with 20 amp diodes to prevent backfeed.
 
Last edited:
Joined
Nov 6, 2017
Messages
227
Location
Minneapolis
According to the Q&A on Amazon, these can't be used in parallel or series. How did you connect yours to your fixed panel and did you have any problems.

I'm planning to use 2 of the foldable panels in parallel with 20 amp diodes to prevent backflow.
Connected as series using a victron mppt. It worked fine in the afternoon i tested it. Unfortunately havent had full sun to measure the max throughput.

I dont fully understand why it cant do parallel and they dont provide an explanation either. One suggested that they do it to prevent people from messing up their equipment but perhaps someone more knowledgeable can share their thoughts on why this is a problem.
 

76FJ40

Old Fart
SILVER Star
Joined
Mar 1, 2002
Messages
4,939
Location
NOVA
Thanks. I checked with a EE friend and he didn't have a solid answer but suspected that back feeding might be the reason.
 

lx200inAR

SILVER Star
Joined
Dec 12, 2020
Messages
728
Location
Little Rock, AR
Don't have FB, is there any other link?
It's a FB marketplace link, which I find to usually be of questionable validity. The link doesn't go anywhere as far as I can tell. Although, i can't seem to get anything on marketplace to load, so maybe some sort of system outage.
 

lx200inAR

SILVER Star
Joined
Dec 12, 2020
Messages
728
Location
Little Rock, AR
I was responding to the FB link posted a couple weeks ago, probably should have let it go, but didn’t immediately process that it wasn’t September anymore. My apologies.
 

Users who are viewing this thread

Top Bottom