OBD for 5.3 FJ62 (1 Viewer)

Joined
Nov 13, 2020
Messages
73
Location
Dallas Texas
Direction on best OBD for a 5.3 2014 LC9? 1989 FJ62, prefer a plug OBD Bluetooth to iPhone. Looking to catch codes not to program. New owner here and have 4 different shops that updated the Cruiser and all the little pain in the ass situations they point at each other. They run out of patience. It’s kinda chaotic trying to figure out who did what and why. Some of the little cool things various shops did is like to defuse a bomb. Chase one issue and that was a fix for an issue that should have been fixed. Amazed at the crappy detail even at premium shops....
 
Joined
Nov 13, 2020
Messages
73
Location
Dallas Texas
Are you looking for a code reader?
Yes, something I can leave in place but temporary until I can figure out what’s going on. Shop has made a number of changes and runs good for a day then throws codes. And they are like gremlins they change. Long story
 

NCFJ

Supporting Vendor
Joined
Jan 22, 2007
Messages
9,300
Location
Chesnee, SC
You can pull the ECU and send it to Wayne at 150tunes.com and have him clean it up and do whatever you like with it. Good guy that has been doing this a while. He has flashed several computers for me and built harnesses for me as well. He did the computer and harness for my wife's truck.
 

MANUCHAO

omnia mea mecum porto
Joined
Nov 8, 2004
Messages
5,194
Location
MilkyWay
I use a scan gauge permanently on my rig... But recently bought this BT dongle and use torque lite to quickly browse data....
Be aware that literature states it may not be able to clear codes....in some vehicles
I plugged it into all three vehicles and it worked great on all of them, but don't know if it actually clears any codes as I haven't had any....
 

rhah

Admit it, your cruisers jealous
Joined
Dec 23, 2010
Messages
703
Location
ottawa, kansas
ELM 27..... WiFi or Bluetooth plugs into your obd2 port, off eBay for 7$, use your old phone you got laying around and down low as a free obd reader app and boom

monitoring your LS for less than 10$
 

rhah

Admit it, your cruisers jealous
Joined
Dec 23, 2010
Messages
703
Location
ottawa, kansas
Live feed for all obd2 readings

CHEAP, works good enough for the price of next to nothing.

been in mine for little over 100k miles now

66D79D71-D0EC-4BFA-93CB-DB7BCA84E9C1.jpeg
 
Joined
Nov 13, 2020
Messages
73
Location
Dallas Texas
You can pull the ECU and send it to Wayne at 150tunes.com and have him clean it up and do whatever you like with it. Good guy that has been doing this a while. He has flashed several computers for me and built harnesses for me as well. He did the computer and harness for my wife's truck.
 
Last edited:

rhah

Admit it, your cruisers jealous
Joined
Dec 23, 2010
Messages
703
Location
ottawa, kansas
About a year ago the previous owner had new ecu from gm performance installed. When I started my work and saw the issues, well.....California was behind it, so many work arounds to make it pass, as well as VVT issues. Previous wired in toggles to bypass VVT well that complicated things. So I've decided and began ripping stuff off. Going back to basic. Pulled CA secondary sensors, today pulling the toggles. In regards to your response I've taken it to local LS guy and the retune discovered that they put the secondary 02 sensors on and tuned it to what he called speed tune, taking its reading and engine running off data from the sensors instead of the MAS. Ripped all that crap off and back to MAS info to adjust the ecu. In that process discovered bad MAS so replaced that but wait there's more....2 years ago they installed performance air intake and electric fan, well the change in airflow messed everything up, had to change the high flow breather, and the location. But they didn't know bad MAS. Confused yet, me to but tearing it all back and simplifying. Almost there

holler if you need pics, help, or anything. I feel your pain on that one
 
Joined
Nov 13, 2020
Messages
73
Location
Dallas Texas
Heres the back story. About a year ago the previous owner had new ecu from gm performance installed. When I started my work and saw the issues, well.....California was behind it, so many work arounds to make it pass, as well as VVT issues. Previous wired in toggles to bypass VVT well that complicated things. So I've decided and began ripping stuff off. Going back to basic. Pulled CA secondary sensors, today pulling the toggles 2 of them, 1 to shut down the VVT and yes a valet that was hooked to tranmission that they said would only let it go 10mph, chased that 20ft wire last night and it wasnt even hooked to anything. In regards to your response I've taken it to local LS guy and the retune discovered that they put the secondary 02 sensors on and tuned it to what he called speed tune, taking its reading and engine running off data from the sensors instead of the MAS. Ripped all that crap off and back to MAS info to adjust the ecu. In that process discovered bad MAS so replaced that but wait there's more....2 years ago they installed performance air intake and electric fan, well the change in airflow messed everything up, had to change the high flow breather, and the location. But they didn't know bad MAS. Confused yet, me to but tearing it all back and simplifying. Almost there, the maintenance shop that did last major work and addons said hey we do great work. My lawyer said refund and no you didn't. I hate lawyers but in this case I got screwed. Previous owner knows nothing and relied on them, got taken, now they pay. How about that. 2 pre-purchase inspections, flight from TX to CA, broke down in AZ, stranded in desert, got it running and made it to NM, broke down, border patrol helped me near Socorro Mexico because I was in an area they were having a fire fight with Mexican cartel. Got me back to truck after dark and escorted me to help at checkpoint. Once I got to cooler weather and lower altitude made it home. 2 days trip took 4 and last 36 hours awake driving, or overheating. Walked in front door as sun came up. They have no idea how big my psych bill will be from lawyer. They will pay. If you can't tell I'm pissed. But not a quitter.....
 
Joined
Nov 13, 2020
Messages
73
Location
Dallas Texas
holler if you need pics, help, or anything. I feel your pain on that one
Hey I appreciate that. The ECU is good now, the intake and fan good. Ill see how to toggles turn out when I rip them off. I may message you on input
 

rhah

Admit it, your cruisers jealous
Joined
Dec 23, 2010
Messages
703
Location
ottawa, kansas
Heres the back story. About a year ago the previous owner had new ecu from gm performance installed. When I started my work and saw the issues, well.....California was behind it, so many work arounds to make it pass, as well as VVT issues. Previous wired in toggles to bypass VVT well that complicated things. So I've decided and began ripping stuff off. Going back to basic. Pulled CA secondary sensors, today pulling the toggles 2 of them, 1 to shut down the VVT and yes a valet that was hooked to tranmission that they said would only let it go 10mph, chased that 20ft wire last night and it wasnt even hooked to anything. In regards to your response I've taken it to local LS guy and the retune discovered that they put the secondary 02 sensors on and tuned it to what he called speed tune, taking its reading and engine running off data from the sensors instead of the MAS. Ripped all that crap off and back to MAS info to adjust the ecu. In that process discovered bad MAS so replaced that but wait there's more....2 years ago they installed performance air intake and electric fan, well the change in airflow messed everything up, had to change the high flow breather, and the location. But they didn't know bad MAS. Confused yet, me to but tearing it all back and simplifying. Almost there, the maintenance shop that did last major work and addons said hey we do great work. My lawyer said refund and no you didn't. I hate lawyers but in this case I got screwed. Previous owner knows nothing and relied on them, got taken, now they pay. How about that. 2 pre-purchase inspections, flight from TX to CA, broke down in AZ, stranded in desert, got it running and made it to NM, broke down, border patrol helped me near Socorro Mexico because I was in an area they were having a fire fight with Mexican cartel. Got me back to truck after dark and escorted me to help at checkpoint. Once I got to cooler weather and lower altitude made it home. 2 days trip took 4 and last 36 hours awake driving, or overheating. Walked in front door as sun came up. They have no idea how big my psych bill will be from lawyer. They will pay. If you can't tell I'm pissed. But not a quitter.....

Quick and simple.... relocate your mass to right in front of your throttle body. Mine does not run right if I do not have it set right off the elbow. Fought a bad mass for a long time till I moved it as close to the throttle plate as possible
 

Users who are viewing this thread

Top Bottom