1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

O2 Sensor Removal Help

Discussion in '80-Series Tech' started by BROKEROB1, Aug 19, 2006.

  1. BROKEROB1

    BROKEROB1 SILVER Star

    Messages:
    501
    Likes Received:
    38
    Joined:
    Jul 19, 2004
    Location:
    York, PA
    I am in the process of trying to get the O2 sensor nuts off. They are beyond rusted. I can get an 11mm on and really torque it, but it is SO rusted. I have been hitting the nuts with PB Blaster everyday, for the last week. I am not sure of what my options are for getting the nuts off, b/c it looks like I can't destroy the stud. Any real time help or thoughts would be greatly appreciated.

    Thanks
     
  2. cruiserdan

    cruiserdan SupportingVendor Emeritus Moderator

    Messages:
    21,816
    Likes Received:
    5,389
    Joined:
    Mar 27, 2003
    Location:
    Surrounded by Cruisers from all over the world
    Get a nut splitter. You may also try some heat.
     
  3. BROKEROB1

    BROKEROB1 SILVER Star

    Messages:
    501
    Likes Received:
    38
    Joined:
    Jul 19, 2004
    Location:
    York, PA
    Dan,

    Thanks for the help. I can't tell you how much I appreciate your help in overnighting those 02 sensors. We leave for the midwest tomorrow morn at 5am, so hopefully heat and/or a nutsplitter will work.

    THANKS AGAIN, DAN.
     
  4. BROKEROB1

    BROKEROB1 SILVER Star

    Messages:
    501
    Likes Received:
    38
    Joined:
    Jul 19, 2004
    Location:
    York, PA
data-matched-content-rows-num="2,1" data-matched-content-columns-num="1,4" data-matched-content-ui-type="image_stacked" data-ad-format="autorelaxed">