Need help....bad

Joined
Aug 1, 2008
Messages
1,188
Location
Leawood,Kansas
Anymore meaning what? Anymore slipping? Then yes, on the way to get ATF if needed I was cruisin at 15-20 miles an hour at 2000 RMP, Just put it into lower gears and it somewhat caught, checked the fluid level, it was fine....turned the truck off for a little while (not even five minutes) drove it back, it was fine, then to the gym today, it was fine, and so on, it was fine.....:confused: makes no sense at all to me.

-Carl
 
Joined
Aug 1, 2008
Messages
1,188
Location
Leawood,Kansas
Fluid was changed at a local jiffy lube not even a month ago....I think it may be beyond fluids, its in the shop right now getting looked at (I know people probably think I'm stupid for this but oh well) I was coming home earlier today, it slips and I start slowing down, put it into lower gears again, nothing, get onto a side street, turn it off, sit and wait. Turn it back on, it was fine, jsut dropped it off at Molle, just to see what the :censor: is going on.....:crybaby::bang::mad:

-Carl
 
Joined
Oct 7, 2003
Messages
1,007
Location
Kansas City, MO
Tranny

Hold up. Have you had the pan off and cleaned the screen? Have you done the Rodney party trick? Have you done the Rodney flush? Do searches on those. I had the same symptoms on the 62 I had, and after doing those two everything worked fine after that. The metal filter/screen was super clogged. Try all those first. If you have and still a prob, buy a used A440f and put it in. That's my .02cents.


Ex
 
Last edited:
Top Bottom