Front driver side squaeks over ruts/bumps/potholes (1 Viewer)

Joined
Jan 31, 2010
Messages
1,250
Location
US
I have this squeak now almost every time I hit any bumps. It started off every bigger bump a few months ago. Driving on PA town roads its very annoying.

Wheel bearings are tight, grease is filled in knuckles, checked the dreaded steering box area for possible cracks but didn't really delve into it though after cleaning up where it bolts to the frame it looks fine.

Could this just be worn springs/shocks? I did push up and down on my ARB and heard the shocks compressing, etc no noise really. Tried hitting the frames at various points to see if I could trigger anything.. nothing. Its not a clank like the cracks in the frame would sound from that some people have experienced and my steering is fine ever since I did the front end a while ago.

It'll be 1-2 months til I can afford new springs/shocks so I'll just keep looking for now.

:meh:
 

crikeymike

Exit Offroad - Dobinsons Specialist
Supporting Vendor
Joined
Jun 6, 2005
Messages
842
Location
Jacksonville, Florida
 
 
 
Front end bushes? Sway bar links, control arms, shock bushes? Those can produce some funky noises when they're worn out or loose.
 
Joined
Jan 31, 2010
Messages
1,250
Location
US
Front end bushes? Sway bar links, control arms, shock bushes? Those can produce some funky noises when they're worn out or loose.
Well my shock bushings are have tons of little cracks in them in the front, didn't check sway bars but they might be a little better than the shock bushings Control arms are tights and leak free

Thanks I'll recheck all that stuff.. I won't be able to eliminate much til at least new shocks which I don't want to put on til I have new springs too. O well
 
Joined
Feb 25, 2009
Messages
3,575
Location
Richmond, VA
I had a similar sqeak in the front and it ended up being the springs rubbing on the lower spring perch.
I have new springs now, but with the old springs I put rubber hose over the end of the spring about 6-8 inches or so can't remember what size rubber hose.
 
Joined
Jan 31, 2010
Messages
1,250
Location
US
The spring rubbing is a good possibility. I double checked steering box again and no common cracks in the welds no rust, etc.

Checked control arm bushing, sway bar bushings and shock bushings. Found the one sway bar busing on drivers side is split in half and cracked in a few places.

From what I see there is the main bushing for the sway and a smaller one towards the front near the axle that is where I have the split/cracked one.

Sigh, spring gets more and more projects loaded into it.
 
Joined
Jul 24, 2007
Messages
3,384
Location
Sudbury Ontario Canada
 
 
Torque down your control arm bolts at the front axle (2/side). I guess mine got a little loose last summer and I had the same squeaking. Tightened the hell out of said bolts and the squeaks went away.

Find out if its the bolt or the nut that has the locking feature before torquing though. I dont remember which one it is off hand.

D
 
Joined
Jan 31, 2010
Messages
1,250
Location
US
Torque down your control arm bolts at the front axle (2/side). I guess mine got a little loose last summer and I had the same squeaking. Tightened the **** out of said bolts and the squeaks went away.

Find out if its the bolt or the nut that has the locking feature before torquing though. I dont remember which one it is off hand.

D
Thanks darwink I'll have to check those too
Just looked it up in the FSM you hold the nut and torque the bolt on the control arms.
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom