FJ60 Fuel filter question (1 Viewer)

Joined
Feb 26, 2020
Messages
9
Location
Albuquerque, NM
I replaced an old fuel filter that is located by the rear fuel tank with one from Cruiser Corps. (See photo) before was running fine, now vehicle won’t start. There is fuel in the filter (both rear and in filter toward fuel pump) Do I need to use a different fuel filter? Air pocket? Anyone else have this issue? Thanks.

4CE2DBF4-F790-4F59-8A82-4637DE8FC4CA.png
 

OSS

Joined
Jun 30, 2017
Messages
3,170
Location
Oblivion
The FJ60 only had one fuel filter - in the engine compartment.
If the fuel pump is working correctly, it can suck air until it gets fuel (It can pump air). So if the pump is good it'll purge the fuel line of air.
 

ToyotaMatt

Factory Focus-Point Mind-Set Approach
Supporting Vendor
GOLD Star
Joined
Aug 12, 2007
Messages
13,616
Location
EAST COAST
I replaced an old fuel filter that is located by the rear fuel tank with one from Cruiser Corps. (See photo) before was running fine, now vehicle won’t start. There is fuel in the filter (both rear and in filter toward fuel pump) Do I need to use a different fuel filter? Air pocket? Anyone else have this issue? Thanks.

View attachment 2505761


Did you install 2 new EFI type clamps along with the new oem toyota genuine parts filter element ?

if not you could be sucking air ........?



1606536084801.jpeg
 
Joined
Feb 26, 2020
Messages
9
Location
Albuquerque, NM
I replaced the fuel filter in the engine bay (I think on replacement of the rear one it might have threw some debris into the front one). After that it worked fine!
 

FjLobo

SILVER Star
Joined
Dec 9, 2019
Messages
43
Location
Boerne
Check the fuel hoses at the tank. Could be cracked and sucking air or leaking on return.
 

Users who are viewing this thread

Top Bottom