Fj60 engine problems

Joined
Jul 27, 2021
Messages
5
Location
London, KY
Visit site
Hello I have a 1986 fj60 with a 2f in it it has been parked a year and a half because it broke down then I moved but I finally got it to where I moved and it fired right up but there is clicking in the top of the engine and the oil pressure gage is maxed out what are the possible problems?
 

OSS

Joined
Jun 30, 2017
Messages
3,680
Location
Oblivion
Visit site
It might just need a valve adjustment to get rid of the clicking. Not sure what advice to give about the apparent high oil pressure.
 

2mbb

SILVER Star
Joined
Sep 1, 2003
Messages
5,232
Location
WC, CA
Visit site
replace the oil pressure sender with a gauge, temporarily. More than likely it is an electrical problem with the oil pressure sender or gauge. But if it has been just sitting a year and a half, you should change the oil and oil filter.

What were the problems that caused it to "break down" a year and a half ago?

1627420851756.png
 
Joined
Jul 27, 2021
Messages
5
Location
London, KY
Visit site
replace the oil pressure sender with a gauge, temporarily. More than likely it is an electrical problem with the oil pressure sender or gauge. But if it has been just sitting a year and a half, you should change the oil and oil filter.

What were the problems that caused it to "break down" a year and a half ago?

View attachment 2743227
I've already changed oil and oil filter and put sea foam in it to help clear out any build up in the oil system. I was driving it down the road crusing at 55mph and it lost power (lost power as in the engine wasnt responding to the pedal) then it died completely shut itself off then I tried to crank it and it would turn over but wouldn't start
 

2mountainfish

NOTW
SILVER Star
Joined
Jan 18, 2014
Messages
906
Location
Bishop, Ca.
Visit site
Check the site glass on your carburetor and make sure that you're getting fuel to the carburetor. Also check your fuel filter and make sure you're getting fuel to the filter. If no fuel in either place it could be a clogged line ,broken pick up or failed fuel pump.
 
Joined
Jul 27, 2021
Messages
5
Location
London, KY
Visit site
Check the site glass on your carburetor and make sure that you're getting fuel to the carburetor. Also check your fuel filter and make sure you're getting fuel to the filter. If no fuel in either place it could be a clogged line ,broken pick up or failed fuel pump.
No it runs now that was the problem a year and a half ago the reason I parked it i am having other problems this is the original post I made
Hello I have a 1986 fj60 with a 2f in it it has been parked a year and a half because it broke down then I moved but I finally got it to where I moved and it fired right up but there is clicking in the top of the engine and the oil pressure gage is maxed out what are the possible problems?
 

Users who are viewing this thread

Top Bottom