EGR Fault Pinpointed... Clogged Port of the Throttle Body

Joined
Nov 23, 2006
Messages
168
Location
Tucson, AZ
I've been chasing a recurring P0402 code for low EGR flow by needlessly replacing parts. I downloaded the
Emissions FSM and started troubleshooting today. I found zero vacuum between the Vacuum Modulator and the EGR valve on a fully warmed up engine at 2500 RPM. When I checked to see if there was vacuum at the throttle body on the E and R ports I found the R port completely clogged. Tried cleaning it out with Seafoam and Throttlebody cleaner and got nowhere. It's stopped up pretty good.

Anyone know of some good cleaners that can get through the Throttlebody gunk? Or should I try piano wire or guitar string?
 
Joined
Aug 13, 2013
Messages
105
Best option is to remove the upper intake manifold and clean all the junk out of it. Replace all the little vacuum lines while you're at it.
 
Joined
Nov 23, 2006
Messages
168
Location
Tucson, AZ
Way ahead of you. Upper and lower intakes were cleaned out and all of the hoses were replaced when I did the HG. The ports in question are on the throttlebody. I was just wondering if someone could recommend a product that was better than carb or throttlebody cleaner at cleaning out small orifaces?

Thank you for your reply.
 

Finnyfam60

Driving miss daisy
Joined
Sep 21, 2011
Messages
2,468
Location
Dixon, Ca
Small wire then the liquid cleaners.
 

94SRUNNER

GOLD Star
Joined
Oct 9, 2006
Messages
4,229
Location
Dayton, OH
Pull the throttle body and give a good soak in a throttle body approved cleaner. I agree the small diameter wire will work well. Hell, pipe cleaners might ever do the trick to get the finer particles out. I would also consider using compressed air to assist in the crud removal.
 
Joined
Sep 18, 2013
Messages
1,244
Location
Disneyland
I used a piece of safety wire and a Dremel (think roto-rooter) on a very slow speed with some throttle body cleaner.
 
Joined
Nov 23, 2006
Messages
168
Location
Tucson, AZ
Safety wire did it. Port R was clogged pretty good, but I got it cleared. However, the CEL popped back on. For what ever reason I cannot get the EGR Valve to open. Still no vacuum between vac modulator and the EGR valve above 2500 rpm on a hot engine.
 

Users who are viewing this thread

Top Bottom