EFI fuse

Joined
Apr 14, 2006
Messages
228
Location
Tulsa, OK
Can someone please tell me why I am blowing the 15A EFI fuse every 200 miles or so?

The truck will just die right in the middle of the road... I get out, pop in a new fuse, and it starts right up.

Whats the deal ?





97 LX450 - completely stock
 
Joined
Aug 22, 2006
Messages
246
A few things to narrow it down: Have you had any fuel related troubles before this, does the truck idle funny sometimes, do you throw the CEL? The things on the EFI circuit are: The Engine ECU:eek:, Fuel pump relay, resistor, and sender, Oxygen sensors, Mass airflow sensor, A few VSVs and the EFI main fuse. If I were you, I would replace the O2 sensors and EFI main before checking anything else.
 
Joined
Apr 14, 2006
Messages
228
Location
Tulsa, OK
Is it safe to use a 20A or 25A fuse ?

I need to buy more 15's in the meantime...
 
Joined
Apr 14, 2006
Messages
228
Location
Tulsa, OK
The truck stranded me again tonight...

I don't even know what to actually "check" because everything seems to be working fine. This is an intermittent problem that occurs at random. The Lexus mechanic had the truck for 2 weeks and drove it everywhere, the fuse never blew while he was driving it.

Is it safe to use a 25 fuse instead of the 15 ?
 
Joined
May 26, 2005
Messages
8,169
Location
Phoenix
Website
www.tralaz.org
No. It's a 15 because more than 15 amps on the circuit might burn something. Also, if you have a short somewhere, it's gonna blow a 25 just the same.
 

musthave

😂
Supporting Vendor
GOLD Star
Joined
Sep 4, 2013
Messages
5,439
Location
St. Pete, Florida
What was the issue?
 

Users who are viewing this thread

Top Bottom