EDIC AND FUEL CONTROL RELAY PROBLEMS

Joined
Mar 13, 2021
Messages
21
Location
newcastle
So I’ve wire up the edic and fuel control relay but EDIC motor won’t move. I’ve opened it up cleaned the brushes and stator cleaned out the old grease and put new grease in and it was spinning by hand. I’ve followed the wiring diagram from my original manual plus one I drew up to mark off as I went along. My question is now why won’t it work ? And is it worth getting an auto electrician to look at or to do the dodgy and make a push pull cable up to the cab to shut the engine off. I just need registration to get it on the road !
Below is pictures of the diagram and in the motor and relay
Cheers !

F830A0C4-BD0C-45C0-92A5-8987081474F5.jpeg


E3A20AEC-6013-44E0-8AC9-1C9EC7D5D392.jpeg


9F410FBE-DD10-4E46-BDE7-635516930A6F.jpeg


0F1E0043-6C93-4061-B2D1-F1BF55BC0F89.jpeg


13CDB480-219F-4B69-9467-62871AA56E71.jpeg
 
Joined
Mar 13, 2021
Messages
21
Location
newcastle
So I’ve wire up the edic and fuel control relay but EDIC motor won’t move. I’ve opened it up cleaned the brushes and stator cleaned out the old grease and put new grease in and it was spinning by hand. I’ve followed the wiring diagram from my original manual plus one I drew up to mark off as I went along. My question is now why won’t it work ? And is it worth getting an auto electrician to look at or to do the dodgy and make a push pull cable up to the cab to shut the engine off. I just need registration to get it on the road !
Below is pictures of the diagram and in the motor and relay
Cheers !

View attachment 2756721

View attachment 2756722

View attachment 2756723

View attachment 2756724
 
Joined
Mar 16, 2010
Messages
461
Location
Rossland BC
check your ground that comes off the EDIC and grounds to inside of fender

(check the board and all the solders on the other side of the fuel control relay; remove from back of casing


I also noticed the wire crimp missing a wire....
 
Joined
Mar 13, 2021
Messages
21
Location
newcastle
check your ground that comes off the EDIC and grounds to inside of fender

(check the board and all the solders on the other side of the fuel control relay; remove from back of casing


I also noticed the wire crimp missing a wire....
Yep going to add an extra ground from the motor Mount to the Meg terminal on the battery and the relay Mount to the keg terminal on the battery aswell.
Yeah do you know what wire that would be ? 12v+ to the coil ??
 
Joined
Mar 16, 2010
Messages
461
Location
Rossland BC
EDIC is not the relay

EDIC is the EDIC
there is a ground coming off of the actual EDIC that needs to be grounded or your truck won’t fire
 
Joined
Mar 13, 2021
Messages
21
Location
newcastle
check your ground that comes off the EDIC and grounds to inside of fender

(check the board and all the solders on the other side of the fuel control relay; remove from back of casing


I also noticed the wire crimp missing a wire....
EDIC is not the relay

EDIC is the EDIC
there is a ground coming off of the actual EDIC that needs to be grounded or your truck won’t fire
Yep sorry if that didn’t make sense before but edic is grounded I got the motor to spin by shorting the circuit to prove it works and the relay to works with how it’s wired up. So the issues is now the ground from the relay to the edic circuit when it crosses over limits I think
 

Engineer8000

CAPE FEAR ELECTRONICS
Supporting Vendor
Joined
Aug 16, 2019
Messages
696
Location
SOUTHPORT NC
Are the relays picking up? The schematic shows a fuse inside the relay module, is it blown? I would also check the solder connections for the external wires, they can crack and cause problems.
 
Joined
Mar 13, 2021
Messages
21
Location
newcastle
Are the relays picking up? The schematic shows a fuse inside the relay module, is it blown? I would also check the solder connections for the external wires, they can crack and cause problems.
Yep so I had it opened up and seen them clicking over with the key going to on and start position and I got the motor to move by shorting it to the 12V terminal on the battery.
I’m thinking it’s an earth issue maybe my oil pressure switch is buggered causing no ground
 

Users who are viewing this thread

Top Bottom