Dome light circuit (1 Viewer)

Joined
Oct 6, 2016
Messages
640
Location
Kansas
Pleased to report I picked up my 40th from the body shop. Front bumper paint and a minor rust hole repair on the rear rocker. Shop did a great job paint match is fantastic. Only issue is the battery was dead when I picked it up. I jumped it and drove it home to realize no remote door locks, no radio, no dome light, no key buzzer, no dash clock. I didn't have time to mess with it when I got it home but I put it on the battery charger all night and will swap in a new 10amp fuse today.

Hopfully its an easy fix. My mind raced all night about how the body shop could have arched something when fixing the rust hole. Wish me luck today in getting that circuit diagnosed.
C044664E-7A23-4CAB-A7B2-2DE781BAD4F3.jpeg

RKTINC
 
Last edited:
Joined
Oct 6, 2016
Messages
640
Location
Kansas
Success! 10 amp fuse cured my problem. All items work now including the remote door locks. Only issue now is the starter has a dead spot. I have pulled 3FE starters so I guess I can move to the other side of the block and pull a FZJ starter. I am sure the body shop arkc'ed something. That might explain the dead spot on the starter and the blown fuse. Truck starts and runs fine after a couple of attempts/clicks just like any failing starter would.

Once item I would like a little feed back on. I saw a slight spark when I installed the new 10amp fuse in the Dome light circuit under the hood. Is that normal or do I have a draw?

Thanks,

RKT
 

Users who are viewing this thread

Top Bottom