Coolant/Radiator problems

Joined
Jul 18, 2021
Messages
13
Location
California
Visit site
Hi all currently stuck at a gas station in Gorman, CA. I have a new to me 91 FJ80 w the 3FE. Noticed the temp gauge almost hit red and got the truck off the highway and into a gas station. There's a crack in the coolant reservoir with coolant bubbling and leaking all over the place.

I probably drove 5 mins with the temp gauge rising. The heater wasn't getting hot and just blowing air. I just did a coolant flush before I left and replaced the radiator cap as well.

Any help would be appreciated.
1627654556358859227349738636078.jpg
 
Joined
Jul 18, 2021
Messages
13
Location
California
Visit site
Got a mechanic to do a pressure test and it looks good. Thinking the radiator is clogged. Lots of build up when the cap was taken off.

I'm going to try and limp over to Bakersfield to get the radiator checked out
 
Joined
Aug 22, 2017
Messages
1,535
Location
Los Angeles
Visit site
Definitely looks to me like air in the coolant system. did you properly bleed the system, like have the front end of the car up when filling, have the engine on heat and get the rpm high during bleeding. What is the condition of the rest of the cooling system? when the needle gets around 2/3 of the gauge, the engine temp is probably over 230-235 range
 
Joined
Jul 18, 2021
Messages
13
Location
California
Visit site
Not sure if my mechanic bled the system or not.

Made it to Bakersfield and getting it checked out

But engine temp is staying level and noticably much smoother at 60mph. Heater also works again.

Will update on progress
 
Joined
Aug 22, 2017
Messages
1,535
Location
Los Angeles
Visit site
The overflow tank has a factory vent tube that is too short, and coolant is dumping onto your battery tray and everything behind it. Get a longer tube and and run it down below the battery and wirings. I doubt your reservoir is cracked...
 
Joined
Jul 18, 2021
Messages
13
Location
California
Visit site
Good news: after 12 hours made it home

Bad news: traveling flat, temps went up to 3/4ish of the gauge but going up a steep grade engine definitely got super hot.

Was traveling in 3rd gear and 35 mph up the hills and it was rough.

Heater was blowing hot air off and on.

Not really sure what to check next at this point.
 

TYM4FUN

SILVER Star
Joined
Aug 16, 2012
Messages
2,462
Location
🖕😁🖕
Visit site
Good news: after 12 hours made it home

Bad news: traveling flat, temps went up to 3/4ish of the gauge but going up a steep grade engine definitely got super hot.

Was traveling in 3rd gear and 35 mph up the hills and it was rough.

Heater was blowing hot air off and on.

Not really sure what to check next at this point.
You said there was a lot of build up. From that, I would say a more thorough flushing with cleaner or possibly a new radiator.
 
Joined
Jul 18, 2021
Messages
13
Location
California
Visit site
Also inspect the thermostat or remove it. If no high temps after, get a new one.
The radiator shop inspected the radiator and thermostat and said it was in decent shape. I'm thinking of doing the flush again like you said and replacing the heater hoses and the coolant temp sensor
 

zapatius

SILVER Star
Joined
Mar 30, 2009
Messages
983
Location
Indiana
Visit site
The radiator shop inspected the radiator and thermostat and said it was in decent shape. I'm thinking of doing the flush again like you said and replacing the heater hoses and the coolant temp sensor
You need to get an accurate temperature gauge for the coolant. I use a Koso with the tapped Wit's End coolant elbow.
 

zapatius

SILVER Star
Joined
Mar 30, 2009
Messages
983
Location
Indiana
Visit site
Yup def first thing on my list. Do you have a link to an install?
Nah, it's super easy. You can just get a radiator hose adapter for the sensor and use that. That's what I started with and then went with the Wit's End elbow to clean it up. Wires are tiny and easy to run to dash area.
 
Joined
Sep 4, 2013
Messages
168
Location
LA
Visit site
Nah, it's super easy. You can just get a radiator hose adapter for the sensor and use that. That's what I started with and then went with the Wit's End elbow to clean it up. Wires are tiny and easy to run to dash area.
Didn't even know that product existed. Looks like it's out of stock now, but would be great for us OBDI guys to get a sense for temps easily. @NLXTACY any word on the availability of the tapped coolant elbow? Getting ready to place an order now.
 

Users who are viewing this thread

Top Bottom