COMPLETE: Grom Audio VLine VL2 Group Buy Round 3 (2 Viewers)

Joined
Oct 20, 2019
Messages
367
Location
Ivins UT
I switched to wired CarPlay after trying wireless for a while. Wireless works okay, but I find some neighborhoods with heavy presence of wireless ISPs (I *think*) seems to cause interference. Also the touch screen on the 04 is so bad, that even though visual latency is fine with wireless, I find the input is less reliable.

Plus wireless CarPlay drains the battery quickly, so I was plugging it in either way.

Making and taking calls worked fine for me.
 
Joined
Nov 6, 2019
Messages
127
Location
Miami
I’ve been unable to get ahold of any customer support for my issue with my fuzzy lines side to side. Surprisingly their Facebook person did get back to me after a week only to inform me that they don’t have my email ticket with them.
 
Joined
Mar 2, 2020
Messages
6
Location
San Francisco
I’ve been unable to get ahold of any customer support for my issue with my fuzzy lines side to side. Surprisingly their Facebook person did get back to me after a week only to inform me that they don’t have my email ticket with them.

When I contacted Grom through their website: Support and Questions, an email ticket was automatically opened after sending a message through this page. Did you take the same steps?
 

nimitz

#Flexus
Moderator
Joined
Jun 27, 2016
Messages
59
Location
Seattle
I’ve had good luck doing the chat function on the main Grom page. They seem to stick to normal business hours thought.
 
Joined
Nov 6, 2019
Messages
127
Location
Miami
I’ve had good luck doing the chat function on the main Grom page. They seem to stick to normal business hours thought.
You know. That’s something I hadn’t tried yet. I’ll keep that in mind tomorrow. Yah they have normal business hours but if I’m not mistaken they are on the west coast in a different time zone than me on the east coast.
 

nimitz

#Flexus
Moderator
Joined
Jun 27, 2016
Messages
59
Location
Seattle
Has anyone had luck with this device? Mine displays a white screen about half the time and the other half its blue. Also the wifi wont stay turned on and carplay frequently crashes. Support doesnt seem interested in helping me and im thinking about RMAing it.
 
Last edited:
Joined
Nov 6, 2019
Messages
127
Location
Miami
I haven't had that issue. But I have had the issue 3 times now where it refused to recognize bluetooth and wifi. Shutting down the car and restarting doesn't help because the unit remembers where it was. I had to turn off the car and wait an hour or so for it to power down.
 

nimitz

#Flexus
Moderator
Joined
Jun 27, 2016
Messages
59
Location
Seattle
I haven't had that issue. But I have had the issue 3 times now where it refused to recognize bluetooth and wifi. Shutting down the car and restarting doesn't help because the unit remembers where it was. I had to turn off the car and wait an hour or so for it to power down.
I'm getting ghosted my support chat right now because i asked for an RMA. Super convenient that it took them 3 months from when they took my money so i cant do a chargeback. I'm not very happy about this.
 
Joined
Nov 6, 2019
Messages
127
Location
Miami
I'm getting ghosted my support chat right now because i asked for an RMA. Super convenient that it took them 3 months from when they took my money so i cant do a chargeback. I'm not very happy about this.

I have had the best support from their facebook chat. I got ghosted on warranty chat through their website and told I didn't make a ticket. Then I posted my video to the facebook chat. Then I was told that since the oem screen is analog my blurry static lines were always there and there is nothing they can do about it. Item is working as intended.
 

nimitz

#Flexus
Moderator
Joined
Jun 27, 2016
Messages
59
Location
Seattle
I just figured out how to RMA this thing and its going back. I hate to be a downer and am grateful for the group buy, but having to wait so long to get it and getting almost no support for something that costs so much is a no-go for me. Constant issues from day one and one of the support techs even tried to call me out on GXOR which I very much did not like.
 
Joined
Nov 6, 2019
Messages
127
Location
Miami
I just figured out how to RMA this thing and its going back. I hate to be a downer and am grateful for the group buy, but having to wait so long to get it and getting almost no support for something that costs so much is a no-go for me. Constant issues from day one and one of the support techs even tried to call me out on GXOR which I very much did not like.
Do you have a link to the call out? I’d like to see that.
Overall I’d rate the vline a 6/10. Yah it does things I wanted. Not always, and customer support is lacking. And I have fuzzy blurry lines in my background.
 
Joined
Oct 20, 2019
Messages
367
Location
Ivins UT
I posted a video with some of my thoughts:


Its not amazing, but it gets the job done if you don't have any showstoppers in your way, and its a better option that not having any solution for cell phone integration.

Apologies for the issues people ran into, I'm guessing silence elsewhere means it's working for other people enough.
 

nimitz

#Flexus
Moderator
Joined
Jun 27, 2016
Messages
59
Location
Seattle
I posted a video with some of my thoughts:


Its not amazing, but it gets the job done if you don't have any showstoppers in your way, and its a better option that not having any solution for cell phone integration.

Apologies for the issues people ran into, I'm guessing silence elsewhere means it's working for other people enough.
Definitely not upset with you, I guess I had high hopes plus the wait, plus the cost ended up making it a bit of a letdown. I love it when it works and am mad as hell when it doesn’t. Thanks again for organizing this.
 
Joined
Feb 18, 2020
Messages
66
Location
Richardson, TX
Does touch/flick scrolling work on the newer screen? Biggest letdown of the 04 screen tbh.
No, have to use the arrows.

The screen in my 2010 isn't great, in fact this has made me interested in seeing if a replacement is possible. Of course at that point you might as well do the Tesla type replacement.
 
Joined
Mar 2, 2020
Messages
6
Location
San Francisco
It's been pretty solid so far for me. Wireless carplay got annoying since both my wife and I drive our GX, but I installed a USB port in the cigarette lighter connected to the carplay USB port, so we just use wired carplay.

Sometimes the screen won't respond or the unit appears to disconnect randomly, which is annoying and I am still trying to figure out why. But when it works, and the fact that there is no longer a phone holder on the dash or USB converter for charging, makes it worth it to me.
 
Joined
Oct 20, 2019
Messages
367
Location
Ivins UT
It's been pretty solid so far for me. Wireless carplay got annoying since both my wife and I drive our GX, but I installed a USB port in the cigarette lighter connected to the carplay USB port, so we just use wired carplay.

Sometimes the screen won't respond or the unit appears to disconnect randomly, which is annoying and I am still trying to figure out why. But when it works, and the fact that there is no longer a phone holder on the dash or USB converter for charging, makes it worth it to me.

when I switched back to using wired car play I think I had something like this happen too. I made sure to unpair the phone and vl2 and it seems to help.
 
Joined
Mar 2, 2020
Messages
6
Location
San Francisco
If anyone is having inconsistent connectivity with wired CarPlay, after doing some research this seems to be common with CarPlay. In Settings > TouchID and passcode (or faceID and passcode) you need to make sure USB accessories is turned on at the bottom.

I drove 700 miles round trip this weekend and had lots of issues half way before finding this fix. Everything was perfect the second half of the trip. Being that I am an Apple Music and google maps user, the unit has been a solid update.
 

Users who are viewing this thread

Top Bottom