"Clunk" noise when changing to recirculate on AC

Joined
Jul 24, 2021
Messages
2
Location
Charlotte, North Carolina
Visit site
Just cleaned out my blower motor and evaporator box. Upon placing everything back together I noticed a "clunk" noise when changing from outside air to recirculate. Only in this direction do I have the issue, not the other way around.

Linkage does not appear to be rubbing on anything. AC Blows cold and the flap does work.

Is this normal? Any ideas on how to fix?

See video in link:
 
Joined
Mar 17, 2019
Messages
201
Location
Georgia
Visit site
There is a linkage with a lobed cut out that opens and loses a much smaller air door opposite the large one there. It seems to close more quickly and harshly than the front (literally playing with this thing today). I'm guessing the foam on the door that seals it and keeps it quiet has degraded.

Jason
 
Joined
Jul 24, 2021
Messages
2
Location
Charlotte, North Carolina
Visit site
There is a linkage with a lobed cut out that opens and loses a much smaller air door opposite the large one there. It seems to close more quickly and harshly than the front (literally playing with this thing today). I'm guessing the foam on the door that seals it and keeps it quiet has degraded.

Jason
You're right.

Tore everything apart again and the foam is coming off and the issue is with one of the doors. Those flaps are way up in the dash. Not worth to handle at the moment.

Must have been happening for awhile and I didn't notice. Going to leave as is and get to this when other issues arise.
 

Users who are viewing this thread

Top Bottom