Bad fuel Milage??

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, Skimlinks, and others.

Joined
Jun 13, 2010
Threads
31
Messages
156
Location
PA
I know that I gonna get s***ty gas milage no matter what.So I just put more gas in.Lately it seemed really bad so I kept count of gas and milage.I'm getting 8-9mpg:bang:..........that don't seem right.I use to get 11-12.What could it be?I thinking o2 sensors.I haven't ever replaced them as long as I owned the rig(5 years).What scares me is the nut and the stud are so rust they look like one.I have a 1994 Cruiser with 248,000 miles, 35" tire,and 4.88 gears.I just replace spark plugs,wires, cap and rotor.I do keep up on all PM.Anyone have any ideas?Maybe 8-9mpg is acceptable,but it seems low to me??
 
That seems low
If you are just driving around town and no highway then that might be it, but still seems low
I run 35's and 4+ inches of lift stock gears and get between 9and 14 mixed driving.
It could be the O2's
Is the truck throwing any codes?
 
That seems low
If you are just driving around town and no highway then that might be it, but still seems low
I run 35's and 4+ inches of lift stock gears and get between 9and 14 mixed driving.
It could be the O2's
Is the truck throwing any codes?
Yeah, mixed driving.I do have a CEL on, my mechanic told me it was an egr code.I didn't think that would effect gas milage.I've had that code for awhile......
 
there was a recall on the O2 sensers for the 1994 model, if they have never been replaced, take it to the dealer and they will replace them for you for free.
 

Users who are viewing this thread

Back
Top Bottom