92 LC dies periodically while driving (1 Viewer)

Joined
May 7, 2007
Messages
6
Location
SLC
I have a '92 LandCruiser, 226K miles, that dies periodically while driving. It's my wife's car, and I told her I'd drive it a while so I could see what's happening. Well, it died on my way into work this morning. It seemed like it lost all power to electronics--even the clock reset to 1:00am. I coasted to a stop, turned the key and it fired right up and I drove the rest of the way to work without any problems.

I'm not mechanically-inclined, but have a bro-in-law who owns a tire store who has looked at it and can't figure it out.

Any suggestions would be appreciated.
 

e9999

Gotta get outta here...
Moderator
Joined
Sep 20, 2003
Messages
17,462
Location
US
Welcome to the site!

And yes, you'll be better off in the 80 section, I'll move this there now.
 

Grench

SILVER Star
Joined
Jun 15, 2006
Messages
2,837
Location
Lincoln, NE
Hmm...

A quick easy possibility is to check the grounds. Clean the battery posts & cables, check the ground to the body, block, starter, alternator. Clean both ends of the wires to make sure they are making good contact.

I'm chasing a ghost myself so I know it can be frustrating. The above is a nice place to start because it's easy. It does sound like you have an electrical issue somewhere though.
 
Joined
May 21, 2004
Messages
1,576
Location
MN physically, MI spiritually
I think the EFI wire on 91/92 under the fuse box in the engine compartment has a short and rubbing problem. Check there as well as the battery connections and the ground strap as others have mentioned.
 
Joined
May 7, 2007
Messages
6
Location
SLC
The problem was a faulty battery. I replaced it on a hunch and no problems since.
 

Users who are viewing this thread

Top Bottom