1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wiper pivot pins not turning

Discussion in 'FJ55 Iron Pig Preservation Society' started by n2666s, Feb 21, 2007.

  1. n2666s

    n2666s SILVER Star

    Messages:
    2,622
    Likes Received:
    7
    Joined:
    Feb 21, 2006
    now my windshield wipers just crapped out on a very rainy day...............motor and wiper link is working BUT the wiper pivots are not turning....always something on "Rusty"............. 78 pig :)..........any ideas/suggestions before I try to take the dash apart + remove the AC :confused:..................... checked the threads but nothing on repairing the wiper system or trouble shooting it :(

    Lou
     
  2. toddslater

    toddslater

    Messages:
    1,498
    Likes Received:
    3
    Joined:
    Oct 31, 2002
    Location:
    Kennett Square
    If the motor is motoring and the link is going back and forth...seems that the pins would either have to be moving or somehow busted. Are you sure the nut that holds the wiper arms on is tight ? If not, the little threads on the arm ends of the pivots can strip and the pivot just does it's thing and the wiper will sit there lifeless. If that what you didwhen you say above that you checked the threads....then unfortunately I think your taking the plunge :frown:
     
  3. n2666s

    n2666s SILVER Star

    Messages:
    2,622
    Likes Received:
    7
    Joined:
    Feb 21, 2006
    Todd, checked all the easy stuff :( will have to tear into it tomorrow...........don't particulary want to get underneath the dash...........will try taking out the aftermarket stereo system the PO styuck in there........then the A/C ...........yes. it does have an A/C and it blows real cold :)

    Lou
     
  4. toddslater

    toddslater

    Messages:
    1,498
    Likes Received:
    3
    Joined:
    Oct 31, 2002
    Location:
    Kennett Square
    Dropping down the ac blower box isn't too bad...but it has to be done to get the radio out and access to see what's what up there.
     
  5. n2666s

    n2666s SILVER Star

    Messages:
    2,622
    Likes Received:
    7
    Joined:
    Feb 21, 2006
    Todd, you are right; dropped the A/C, took out the radio the PO had installed monster after market thing and you were right on.........the radio had pushed the linkage out of the pivot pin......snapped it back in and they are running like new .........owe you a beer next time you are this way...give me a holler :)

    Lou
     
  6. toddslater

    toddslater

    Messages:
    1,498
    Likes Received:
    3
    Joined:
    Oct 31, 2002
    Location:
    Kennett Square
    Glad to hear it wasn't too painful and that it's all back together sans PO monster radio and working again. I wish the same could be said for the t-stat replacement in my daughters 62. Busted 2 outta 4 cover housing bolts, pulled everything and was able to heat and extract #3...number 4 was a drill and retap procedure. It happened late in the day yesterday and nobody had an outlet gasket (between the head and t-stat lower housing). Gasket will be here Monday and then she'll be up and running again. Replaced the t-stat in the pig two weeks ago....maybe 15 min operation as everything cooperated..yesterday well a couple hours of swearing. Seems to always happen to the ones we count on for DD chores.