What is this?? (1 Viewer)

Joined
Jul 15, 2020
Messages
71
Location
83638
Found out the "what is this" was a broken on/off switch tied to the dome light. Removed the switch and my dome light works.

Another problem.... I noticed I was missing a high beam light blub in the instrument cluster. Replaced it and now it's on constantly except when I toggle the high beams on then it goes out. I expect the high beam switch is missed wired but to access it inside the steering column? Ideas???
 

dmaddox

SILVER Star
Joined
Nov 7, 2003
Messages
2,421
Location
Long Island, NY
 
 
 
Good evening. I know it's been a rough start. First off, hang in there man. This will all get sorted.

Electrical issues, it will seem like fixing one generates six more. Do you have a wiring diagram? (attached) for you / Toyota.

Here is also the Haynes Information on the wiring diagram:
Haynes1978A.jpg


And:

Haynes1978B.jpg


Now, onto your high beam staying on. Obviously, your harness has been tapped into more than we can probably guess, so I'd recommend using these, look at thee wires, and diagnose.

I assume you (I don't mean to offend) are pushing away from you for hi-beam, pulling back for dim, and the light stays on? Check into the dimmer switch wiring.

Get everything sorted out, go along with the SA ribbing, its part of the welcome/hazing. We are here to help.

Last, pictures are worth 1000 answers, so anything we can help with, post a pic - and we can help you dig into it. My wiring demons are just ahead!

Welcome again, keep at it, and don't let us offend you. Have a great evening!

-dallas
 

Attachments

Joined
Jul 15, 2020
Messages
71
Location
83638
Thanks, really appreciate the help!! I hope being my FJ is a SA...the wiring diagram isn't too different.
I have pretty thick skin as well.
 
Joined
Jul 15, 2020
Messages
71
Location
83638
My next big project is going to be pulling out the after market AC and installing OEM heater. I think the heater install should go pretty good as the bolt holes in the firewall at there and I think the blackout plate in the engine compartment is for the blower. The two plugs hanging below the blackout plate I hope are for connecting up the power.
20200716_094559.jpg
20200816_131122.jpg
20200716_094559.jpg
20200816_131122.jpg
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom