turbo boost indicators at the dashboard hj61

Joined
May 24, 2022
Messages
5
Location
netherlands
hello LC fans

i have a problem : my turbo boost indicators at the dash are lighting up continously ; as well the green one as the red one
see pictures; the green one should light up at 2 psi and the red one at 15 psi
now in the motor compartment nearby the watertank of the whipers you see the pressure switches with the tube connections but in the technical drawings i see them in the vakumsydtem; i dont understand because thes are pressure valves and not working on vakum i believe and i dont know how to connect the the tubes to the turbo envirement
pressurizingen the valves shows a switch action on the electrical wires but dont change the light glowing at the the dash
question : does someone has for me the electrical drawing with the pressure valves and the wiring of the indicators(hookup)
question: can somebody help me out to get the indicators working properly agin
thnx
grtz robertcruiser

64bbb92f-596f-46e1-990b-db9820a33e0b.jpg
b159df73-2e7c-4b51-bf23-529afe218b91.jpg
 
Joined
Feb 24, 2012
Messages
781
Location
Sweden
1:Check ground connection on the vacuum switch bracket.
2:Looks like you need new alternator brushes.
2015-05-22 17.20.18.jpg

Vacuum connection on the left side of the yellow T
 
Joined
May 24, 2022
Messages
5
Location
netherlands
1:Check ground connection on the vacuum switch bracket.
2:Looks like you need new alternator brushes.
View attachment 3174333
Vacuum connection on the left side of the yellow T
hello thnx sved voor giving comments; ecuse my late message; i ws very bussy;i will follow your suggestions; about the brushes itwas the charging light relay grtz robert
 

Users who are viewing this thread

Top Bottom