Ticking after PM (1 Viewer)

Joined
May 19, 2005
Messages
1,728
Location
Small Waves, FL
Happy Monday,

Did quick search first; still have questions.

PM done this weekend:
3 new OEM belts.
Replaced valve cover gasket; new spark plug seals (both VCG and seals hard and brittle); cleaned throttle body; new TB gasket; new ventilation hoses, new PCV and grommet;
Flushed radiator, checked thermostat opening temp, new coolant.

Ticking noise is heard in drivers foot well. Only while accelerating and under normal load (driving).

Sounds more like a vacuum hose than anything metallic. Pretty sure all hoses reinstalled correctly, and nothing torn or cracked.

What did I miss or do?

p.s. LC has 163K miles
 
Joined
Sep 6, 2007
Messages
319
Location
Nashville, TN
just spit-balling here.. but maybe air in the coolant lines or heater core? Also, there are several vacuum hoses in and around the throttle body as you know - you may have disconnected one at the non-TB end down near the back of the manifold. worth checking, but I would expect it not to run well.

Let us know what you find!
 

Dave 2000

Not all Land Rovers are useless!
Joined
Jan 24, 2009
Messages
4,014
Location
Spain
Possible blow from exhaust manifold? Did you put a spanner on them during your PM....you know...just to check? Sometimes if you have a failing exhaust manifold gasket and you start to tighten things up the gasket fails, the resulting 'blow' actually sounds like a ticking, even stranger is you can rarely hear it when under the bonnet but it is quite prominent when under load i.e. driving. Flexible exhaust joint can 'tick' when it gets a few miles on it. Try making the noise lessen by coasting and then accelerating hard to see if the noise is louder the harder you work the engine. Spark leads when not quite on the plug might not produce a misfire but will tick if any spark is jumping to earth, grasping at straws but heh every little helps.

regards

Dave
 
Joined
May 19, 2005
Messages
1,728
Location
Small Waves, FL
Found the hose! Little one that connect to bottom of EGR modulator (green spaceship). Easy to miss; easy to find.

Need to remove this pesky EGR system!

Thanks all....
 

Dave 2000

Not all Land Rovers are useless!
Joined
Jan 24, 2009
Messages
4,014
Location
Spain
As you sounded so confident that you had put back all the pipes I was thinking too deep, glad you have it sorted

regards


Dave
 

Users who are viewing this thread

Top Bottom