Surging Idle with A/C on (1 Viewer)

Joined
Sep 14, 2007
Messages
45
Location
Mandeville, LA
Hi,

I have a 94' with what seems to be a surging problem with the A/C idle. Here what she does;
With the a/c on the compressor will engage and the idle will stay around 600-800 rpms. After running for about 15 sec or so the copressor will disengage and the truck will still call for the idle to increase. Since compressor is not engaged the truck will idle up to 1000 rpms then make its way back down to the 800-900 range. At this point the cycle will start all over again.
The AC temp is cold and seems to be working properly except for the surging idol. I replaced the fan clutch with the blue last summer.
Do you think its the engine coolant shut off switch or the thermister?
The system is charged with 134a
This does not happen with the a/c fan on high.

Thanks,
Check
 
Last edited:
Joined
Feb 13, 2007
Messages
216
Location
Fort Worth, TX
 
 
It may be as simple as needing a charge. If the refrigerant is low the A/C compressor will cycle on and off every few seconds. It will cool when this first starts but will get worse with time.
 
Joined
Sep 14, 2007
Messages
45
Location
Mandeville, LA
Fixed!

The problem I had with the engine surging during the normal cycling of the A/C compressor was fixed. During the removal and replacement of the valve cover gasket, I decieded to clean the Throttle Body. I shot Mercury Power Tune (for outbboard motors) in all the holes. It cleanded up well. I also replaced the PCV valve and grommet. One of these two fixed the surging problem. Or it could have repaired itself when i reinstalled the throttle cables.

Oh. BTW. the PCV valve was a biatch to remove even with the Valve cover off and me standing on top!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom