PSA: LX570 vibration fixed with new transfer case oil (1 Viewer)

Joined
Sep 16, 2020
Messages
43
Location
Atlanta
Hey everyone!

I've been lurking on here for years with my 100-series and recently have picked up a LX570 in amazing shape locally. The only issues I've been experiencing is a slight vibration when turning the wheel full lock at low speed. I was initially concerned this could be an issue with the rack and pinion or maybe some bearing but after reading a thread from a cruiser forum in Australia about the issue being fluid related I thought I'd go ahead and change out the fluids in the transfer case to give it a shot.

The LX has 120,000 miles on it and although dealer maintained, I don't believe the transfer case or diff fluids have ever been changed. After changing out the transfer case oil with Mobil 1 75W-90 I can report that the vibration has been completely eliminated! I was absolutely shocked and thrilled at the same time that this ended up being a very simple fix.

Hope that helps in case anyone else ever runs into that.
 
Joined
Jun 7, 2020
Messages
1
Location
Canada
Hey everyone!

I've been lurking on here for years with my 100-series and recently have picked up a LX570 in amazing shape locally. The only issues I've been experiencing is a slight vibration when turning the wheel full lock at low speed. I was initially concerned this could be an issue with the rack and pinion or maybe some bearing but after reading a thread from a cruiser forum in Australia about the issue being fluid related I thought I'd go ahead and change out the fluids in the transfer case to give it a shot.

The LX has 120,000 miles on it and although dealer maintained, I don't believe the transfer case or diff fluids have ever been changed. After changing out the transfer case oil with Mobil 1 75W-90 I can report that the vibration has been completely eliminated! I was absolutely shocked and thrilled at the same time that this ended up being a very simple fix.

Hope that helps in case anyone else ever runs into that.
My 2010 LX 570 is doing the exact same thing. I was thinking of replacing the T-case oil before I took it to the dealer, but this post has definitely confirmed I should do that ASAP! Thanks!
 

Users who are viewing this thread

Top Bottom