Power steering issue (1 Viewer)

Joined
Jan 14, 2007
Messages
283
Location
Reno
Been having some issues with the steering being hard to turn occasionally mostly when it is at a stop or slow speed. I was out doing a bit of wheeling the other day and the ps quit working all together. I had replaced the ps pump today and there is still some rough spots mostly halfway through a turn and mostly to the left and does not seem smooth at all. It is not making any noise after the pump went out and is currently not making any now would this be an indication of a bad gear box? It is not leaking at all. Also if I take the cap off of the reservoir it shoots fluid out of it. I am going to double check the crank bolt I had replaced the oil pump gasket a few months ago but the issue was there before and after the replacement. Just wanted to get some input before I look to replace the gear box.
 
Joined
Dec 13, 2008
Messages
3,555
Location
N. West CT.
You can try loosening the adjustment screw on top of the steering box. Maybe it was cranked down while being used with a weak pump...? Or slightly bound. Put front up on stands, engine off, loosend screw on box, cycle steering until and adjust nut til there is no hard spots, start truck still on stands and cycle steering, adjust nut as necessary. Figure do this before you spend the $ for a new box.

Or contamination blocking one of the lines.
 
Joined
Jan 14, 2007
Messages
283
Location
Reno
I will give it a try, lines should be good they are all new. I had it on stands today and seemed fine, not really wanting to spend the $$ unless I have to.
 

Users who are viewing this thread

Top Bottom