1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Passenger side vent noise

Discussion in '200-Series Cruisers' started by Yobnoc, Jul 17, 2017.

  1. Yobnoc

    Yobnoc

    Messages:
    10
    Likes Received:
    18
    Joined:
    Jul 1, 2016
    Location:
    East Tennessee
    Did some searching but can't find anything.

    I've got a vent sound, like it's opening and closing, on the passenger side after starting. Does it 7-8 times and lasts a good 10 seconds. The climate controls are not operational when this is happening.

    Any ideas? 09 LX
     
  2. NLScooby

    NLScooby

    Messages:
    801
    Media:
    1
    Likes Received:
    538
    Joined:
    May 29, 2009
    Location:
    North Carolina
    Did you recently (or did the dealer) replace your cabin filter?
     
  3. Yobnoc

    Yobnoc

    Messages:
    10
    Likes Received:
    18
    Joined:
    Jul 1, 2016
    Location:
    East Tennessee
    Yes
     
  4. NLScooby

    NLScooby

    Messages:
    801
    Media:
    1
    Likes Received:
    538
    Joined:
    May 29, 2009
    Location:
    North Carolina
    Aha. My guess is that when it was done the recirc door wasn't in the proper position or it simply wasn't fit properly. Perhaps you are hearing the recirc door trying to open (or close). I would reinstall the filter....making sure to have the ac system in the recirc. position when you do. I had to "force" my door into the correct position after my dealer messed up that simple chore. There are a few threads on the subject on the board here somewhere....I'll see if I can locate one or two...
     
  5. Yobnoc

    Yobnoc

    Messages:
    10
    Likes Received:
    18
    Joined:
    Jul 1, 2016
    Location:
    East Tennessee
    Thanks! I'll check it after work today.
     
  6. NLScooby

    NLScooby

    Messages:
    801
    Media:
    1
    Likes Received:
    538
    Joined:
    May 29, 2009
    Location:
    North Carolina