Newbie Question (1 Viewer)

Joined
Jan 20, 2010
Messages
154
Location
So Cal
I am quite new to the LC world and 1/4 of :banana: when it comes to being a mechanic.

I was looking under my 94 Landcruiser this afternoon and noticed that a bolt with a rubber piece on it was leaking grease. The bolt is located at the rear wheel passenger side next to the wheel. Should I be concerned? Is it difficult to fix? :confused:
DSC07237.jpg
DSC07238.jpg
 
Joined
Nov 7, 2009
Messages
375
Location
NW Az
The grease should not be a problem on the sway bar link. Does not appear to be a zerk fitting on it unless it is snapped off.
Would not loose any sleep over it at this point.
 
Joined
Oct 3, 2006
Messages
8,112
Location
Medford, OR
The grease should not be a problem on the sway bar link. Does not appear to be a zerk fitting on it unless it is snapped off.
Would not loose any sleep over it at this point.

The OEM fittings don't have a zirk.

It's a sealed unit. The boot is probably split somewhere, and grease is leaking out.

Needs to be replaced at some point, but I wouldn't be in a mad rush to do it.
 
Joined
Jan 20, 2010
Messages
154
Location
So Cal
Thanks for the clarification Ebag333. Do I have to replace the whole swaybar end link or can I just replace the boot?
 
Joined
Oct 3, 2006
Messages
8,112
Location
Medford, OR
I believe you have to replace the entire end. Cdan would know (and have the right prices as well).

Some people have had luck getting a needle grease fitting and squirting grease into the boot (via the hole already there), then sealing it up with some RTV sealant of something similar. (Duct tape for a redneck fix. :hmm: )
 

Users who are viewing this thread

Top Bottom