HJ60 24v series 12v battery charging issue (1 Viewer)

Joined
May 10, 2021
Messages
8
Location
Austin, Tx
Hi Y'all,

I'm curious what the next best move should be for my current (no pun intended) situation. Quick rundown of the truck and batteries:
  • Truck - 1988 UK market HJ60 with 24v 2 battery system
  • As with most of these trucks there is some level of DIY wiring that hasn't aged particularly well
  • I recently changed the batteries with 2 new matching Duracell Group 27 batteries. These two are the same with the +/- reversed.
  • I have a battery balancer that a local shop installed for me. I checked the wiring and it appears to be correct. The battery balancer is a victron energy 24v balancer. The balancer appears to work and when the engine is on it shows "High voltage on upper battery". The indicator lights on the balancer do not light up with the engine off.
IMG_1850.jpg


Anecdotal version of what is happening - I've had the truck for a bit over a year with no issues starting. When I bought the truck the AC and blower fan were not working. More recently I took it in to an auto electric shop to diagnose and fix the AC+fan. They were able to get them working by removing a failing 24v-12v power buck and doing something different that enabled power to the blower and ac compressor. A couple weeks later driving the truck regularly I get a slow crank. I figured it's probably time for fresh batteries (no idea when the previous owner last changed them). I purchased the same two batteries that were already on the truck and swapped them in. All seemed well for a week or so until I started getting slow/no crank again. Checking the batteries in multiple states with a multimeter it seems the lower battery isn't getting enough charge even with the AC off to replenish 12.6v


The data version below. I used a multimeter to check each battery in various situations:
Engine Status & Voltage
Battery CheckedEngine OFF - ColdEngine ON - AC ONEngine ON - AC OFFEngine OFF - Warm
Upper12.716.5615.713.1
Lower11.411.312.1511.72
Series24.127.8627.8524.82

The question is - what is my next best move? Is it probably just a bad battery? Is it a failing alternator? Maybe refresh the series wires? Maybe a stronger battery balancer?

Thanks!
 
Joined
Feb 24, 2012
Messages
762
Location
Sweden
So the AC SYSTEM Is Working on 12V ?
Tapped from the Center tap between the 2 batteries?
If so that explains the current voltage drop on the low side.
 
Joined
Dec 5, 2006
Messages
1,022
Location
Vancouver BC
As Sved says, if your clever electrical shop has hooked the Aircon up to one battery to provide 12 volts, (probably the low side battery judging by your voltages), then your batteries are unbalanced and frying each other. I suspect your Air conditioning is using enough power from one battery to overwhelm your battery balancer.

Disconnect the unbalanced load, and use an external charger to fully charge each battery.

Get your electrical shop to hook up a proper 24 to 12 volt converter from both batteries to run the Aircon.
The battery balancer will likely have an easier time with a more balanced load between the two batteries.

Key to keeping the HJ60 24 volt trucks happy is to never have a different load on each battery... battery balancers work best when there are just small differences to even out between the batteries...
 

Users who are viewing this thread

Top Bottom