HID Headlights

Joined
Apr 8, 2007
Messages
274
Location
Deerfield Beach, FL
Website
www.photos.moore4x4.com
Well the dealership said it wouldn't be in until the 15th, but they lied... It actually came in today. I picked it up around 4:00, drove it home, and have already started tinkering. 1st was the headlights. I changed the bulbs on my 07 to HID's and loved them, so decided to do it again. BTW I love working on new trucks, no dirt or mud falling on you, no rusted together parts, etc. I started about 4:30 and it took me around two hours with interruptions. Here are a couple of pics, let me know what you think...
1st Stock Photo.JPG
Stock Headlights.JPG
Pulled Stock Headlights.JPG
 
Joined
Oct 17, 2007
Messages
111
Location
Lexington, Ky.
Yes, everything plugged right in and the clips for the bulbs work the same. Only thing to remember with this kit, there is no HI/LOW beam, it is only one.
So are they on high beam or low beam ir half in between? Are these the blue ones that are so irritating on the road?:confused:

Woodeye
 
Joined
Oct 17, 2006
Messages
47
Location
Edmonton, AB
looks good i also added a set but went with hellios 6k got high an low worked out good 2 years no burnt bulbs yet set cost $400 installed .
 
Joined
Apr 8, 2007
Messages
274
Location
Deerfield Beach, FL
Website
www.photos.moore4x4.com
So are they on high beam or low beam ir half in between? Are these the blue ones that are so irritating on the road?:confused:

Woodeye

It works on the low beam setting. I am going to contact them and see what is up. My '07 had the same bulbs and they worked on either the LOW or Hi setting. These are from a different company on Ebay, but I'm hoping theres a way to fix it.
 

Users who are viewing this thread

Top Bottom