Dome light switch troubleshooting?

Joined
Sep 14, 2020
Messages
18
Location
Seattle, WA
My rear cargo dome light works great but only turns on intermittently when opening the rear hatch door. I don't see where the switch is - is it inside the latch mechanism?

Also, my main dome light works on all doors except the right rear passenger door. I suspect it's a bad/stuck switch. Looking at the switch in the door it's not obvious how to access/remove or test it. Suggestions?
 
Joined
Mar 21, 2014
Messages
194
My rear cargo dome light works great but only turns on intermittently when opening the rear hatch door. I don't see where the switch is - is it inside the latch mechanism?

Also, my main dome light works on all doors except the right rear passenger door. I suspect it's a bad/stuck switch. Looking at the switch in the door it's not obvious how to access/remove or test it. Suggestions?
Each door will have a separate switch in the door. I'm having the same issue with my cargo light. it is in the push button hatch release. if I push the button when the hatch is open the light will flash.
 

ToyotaMatt

Factory Focus-Point Mind-Set Approach
Supporting Vendor
GOLD Star
Joined
Aug 12, 2007
Messages
16,525
Location
EAST COAST
Website
vintageteqparts.com
My rear cargo dome light works great but only turns on intermittently when opening the rear hatch door. I don't see where the switch is - is it inside the latch mechanism?

Also, my main dome light works on all doors except the right rear passenger door. I suspect it's a bad/stuck switch. Looking at the switch in the door it's not obvious how to access/remove or test it. Suggestions?
Each door will have a separate switch in the door. I'm having the same issue with my cargo light. it is in the push button hatch release. if I push the button when the hatch is open the light will flash.


bad pin switches on each doors are common

bad pin switch on rear hatch is common too

rear hatch one MOTHER to replace


side doors 4 of them easy to replace all low cost parts at dealer ...fyi still availble


Please see BOTH links below , if you diagnose NOT a bad pin switch rather Commonly too , bad lamp internal contacts get shorted out

age and time thind from UV rays damage

LINKS BELOW :









1630950678298.png



1630950740227.png
 
Joined
Mar 21, 2014
Messages
194
bad pin switches on each doors are common

bad pin switch on rear hatch is common too

rear hatch one MOTHER to replace


side doors 4 of them easy to replace all low cost parts at dealer ...fyi still availble


Please see BOTH links below , if you diagnose NOT a bad pin switch rather Commonly too , bad lamp internal contacts get shorted out

age and time thind from UV rays damage

LINKS BELOW :









View attachment 2778897


View attachment 2778899
so my rear hatch where the wire connects to ( a possible ground) is loose in the latch portion. do you know where I can get a new latch? says discontinued on Toyotapartsdeal.
 
Joined
Sep 14, 2020
Messages
18
Location
Seattle, WA
Prev Owner installed the LED dome lights - they're awesome. Just need to figure out the switches. Is there a trick to removing/replacing the passenger door switch? Not obvious from looking at it.
 
Joined
Aug 19, 2016
Messages
97
Location
Portland
This thread prompted me to dig into the rear switch activating the cargo area lamp. I had recently installed LED lights inside and after cleaning the drivers side door switch everything was working... almost. The rear lift gate would not consistently light up the cargo area light when opened. In the end I had a grounding issue caused by corrosion between two surfaces shown in the picture. I removed the two bolts holding the lock mechanism, cleaned everything with contact cleaner and a brush. When I put it together, everything works great.

IMG_1152.jpeg


IMG_1153.jpeg


IMG_1155.jpeg
 
Joined
Mar 21, 2014
Messages
194
This thread prompted me to dig into the rear switch activating the cargo area lamp. I had recently installed LED lights inside and after cleaning the drivers side door switch everything was working... almost. The rear lift gate would not consistently light up the cargo area light when opened. In the end I had a grounding issue caused by corrosion between two surfaces shown in the picture. I removed the two bolts holding the lock mechanism, cleaned everything with contact cleaner and a brush. When I put it together, everything works great.

View attachment 2779089

View attachment 2779090

View attachment 2779091
In the second picture. That tab or male portion is loose from side to side. So I’m assuming that is the flickering issue
 
Joined
Oct 10, 2020
Messages
28
Location
Georgia, USA
my rear cargo light works like a charm - when the engine is off. but when the engine is on, it has the strangest behavior.... when i just open the top, the light DOES switch on automatically, as it ought to. BUT ... as i continue to raise the top, beyond a certain point, it craps out. could it be a grounding issue at the hinge?
 
Joined
Aug 19, 2016
Messages
97
Location
Portland
my rear cargo light works like a charm - when the engine is off. but when the engine is on, it has the strangest behavior.... when i just open the top, the light DOES switch on automatically, as it ought to. BUT ... as i continue to raise the top, beyond a certain point, it craps out. could it be a grounding issue at the hinge?
Mine did the same. And cleaning up the grounding set it straight.
 

Users who are viewing this thread

Top Bottom