Does this look like a ground issue?

Joined
Nov 17, 2021
Messages
2,059
Location
Arlington, Wa
Was driving down the freeway. Noticed it was doing it on the rougher sections

Basically all the lights that come on when you're key on, engine off are blinking.

1991 hdj81. 1hdt. Auto




If not ground, then ideas?
 
Last edited:
Joined
May 15, 2018
Messages
280
Location
Chico Washington
Is it a factory manual? My 91 is and I don’t have the automatic tree in the middle of my gauge cluster.
 
Last edited:
Joined
Nov 17, 2021
Messages
2,059
Location
Arlington, Wa
Is it a factory manual? My 91 is and I don’t have the automatic tree in the middle of my gauge cluster.

It's not a manual.

The truck is stock and as it came from the factory other than exhaust and a lift.

It's imported.
 
Joined
May 15, 2018
Messages
280
Location
Chico Washington
I had the boost and overboost lights and timing belt light on mine come on and stay on at random, I pressed the timing belt button in the gauge cluster and they went off.
 
Joined
Nov 17, 2021
Messages
2,059
Location
Arlington, Wa
I had the boost and overboost lights and timing belt light on mine come on and stay on at random, I pressed the timing belt button in the gauge cluster and they went off.


It's every light on the cluster that comes in with the key. And it was random. It hasn't done it since the video.
 
Joined
Nov 17, 2021
Messages
2,059
Location
Arlington, Wa

Found this. I'll clean up my alt and report back
 
Joined
Nov 17, 2021
Messages
2,059
Location
Arlington, Wa
Alternator is putting out 14.4 at idle.
I cleaned and reattached the connection.

It's been good ever since
 

Users who are viewing this thread

Top Bottom