BVSV "whistle"

Joined
Apr 21, 2006
Messages
2,928
Location
Chattanooga, TN
since i've installed a new violet BVSV, i now hear a whistle sound between 2,000 ~ 2,000 rpm in any gear. i cannot hear the whistle when the truck is stationary and reving to that rpm. i can control the pitch of the whistle using the gas pedal. when driving, once i step on the clutch, the whistle disappears. i took my truck to a shop yesterday and lifted it while the rear wheels were free. i took 2nd gear up to the rpm and no whistle. the whistle also comes with some slight chugging similar to a vacuum leak. any ideas to this madness? i've checked for leaks around the intake and carb. no issues found.
 
Joined
Oct 3, 2005
Messages
543
Location
Oregon
Website
www.hardwickhousewares.com
It is a vacuum leak. I went through this. It's frustrating because the engine has to be under load to show the symptom.

I forget exactly where the leak was on my truck. There were so many. :eek:

Try starting with the components and connections that your new BVSV suypplies vacuum to. Things that come to mind are the dizzy cap, dizzy vent to the cabin interior, and vacuum hose connections to the carb. The hose connections at the base of the carb can be difficult to inspect. Mine would whistle when the advancer port hose popped off.

Sorry I don't have more specific info. I've been in diesel land for a while now. The 2F is getting pretty far back in memory.
 
Joined
Apr 21, 2006
Messages
2,928
Location
Chattanooga, TN
Finally..........Bad EGR!!!!!!!!!!!!!!!!

Well, I finally found where this mysterious vacuum leak was coming from. Because the problem would only happen when the truck was moving under a load, I had to find a shop with a wheel dyno. For $65, the guy let me drive my truck while he poked his head around inside the engine. I rev'd the engine between 1800~2200 rpm, which was when the vacuum "whistle" would kick in & the engine would start to stumble. After about 15 minutes, all of a sudden the whistle quit and the engine was so smooth. I looked up and said WTF? All he did was remove the vacuum hose coming off the EGR. He said it must be bad and either opening at the wrong time or too much? I have no idea what exactly the EGR does except for the fact it deals with Exhast Gas Recirculation and sends or rec's air from lots of other things like EGR modulator, VSV, BVSV, etc. So here's my question(s). What happens when the EGR is not hooked up? Will it starve the engine of anything not being hooked up? Of course, I plan on replacing the EGR but does it just fail or is there some mechanical part inside the EGR that can be replaced? Will a used EGR be sufficient or do you guys recommend a new one?
 
Joined
Nov 26, 2004
Messages
2,475
Location
Texas
That's the mother of all questions. I'm sure mine is bad as well, although when I go through the FSM tests, it passes. When the EGR is hooked up to the modulator, my truck bucks, suges and loses power around 1800-2200 RPM. When I disconnect the EGR, it runs smooth as silk.

Look up EGR bypass. The only problem I've had by it being disconnected, is I'll get some pinging at light acceleration in 4th gear- it is somehow connected to the vacuum advance on the distributor as well.

There are also some mention of cleaning the EGR by removing it and using carb cleaner to break up the carbon deposits in it- might help temporarily.

I think you're taking your chances on a used one- 50:50.

BTW- do you have the EGR downpipe "J-tube" leak as well? I'm just curious, because I do and I wondered if it some how affected the EGR valve.
 
Joined
Apr 21, 2006
Messages
2,928
Location
Chattanooga, TN
When the EGR is hooked up to the modulator, my truck bucks, suges and loses power around 1800-2200 RPM. When I disconnect the EGR, it runs smooth as silk.

BTW- do you have the EGR downpipe "J-tube" leak as well? I'm just curious, because I do and I wondered if it some how affected the EGR valve.

exact symptoms when it is hooked up!!!

not sure about the j-tube leak, probably where the whistle is coming from? i'll sent Cdan a pm and see what a new EGR will run. thanks for the help!
 
Joined
Aug 26, 2005
Messages
114
Location
North of Chicago
exact symptoms when it is hooked up!!!

not sure about the j-tube leak, probably where the whistle is coming from? i'll sent Cdan a pm and see what a new EGR will run. thanks for the help!
Please let us know what you learn - I'm going through a very similar (and FRUSTRATING!) set of issues right now as well.
 
Joined
Nov 26, 2004
Messages
2,475
Location
Texas
Please let us know what you learn - I'm going through a very similar (and FRUSTRATING!) set of issues right now as well.

Is your J-tube leaking?

I just got all the past records for my 60 from the PO. He had the J-tube replaced and the gasket replaced several times over the 10 years he owned it- even by Toyota. I doubt it is related, but don't know how it would pass smog with that obvious of an exhaust leak.
 

Similar threads

Users who are viewing this thread

Top Bottom