Blinker issues

Discussion in '80-Series Tech' started by JMRINS, Feb 19, 2009.

  1. JMRINS

    JMRINS

    Messages:
    227
    Likes Received:
    0
    Joined:
    May 12, 2008
    Location:
    Anderson, SC
    Ok,

    I've searched through the posts, followed procedure, and still can't figure it out. My sister's 80 just wont blink right. Only the right side will work before quickly blowing a fuse. We've changed all bulbs AND blinker relay. Any more suggesstions??? Thanks.
     
  2. MLX450

    MLX450

    Messages:
    630
    Likes Received:
    10
    Joined:
    Apr 10, 2005
    Location:
    WA
    What about the front blinker blub? (Assuming you replaced the rear)

    Does it work with the hazzard on?

    Any trailer wiring harness on that 80?
     
  3. Count_Fred

    Count_Fred

    Messages:
    160
    Likes Received:
    1
    Joined:
    May 31, 2006
    Location:
    Yamhill, OR
    I second looking at possible trailer harnesses. I took a bump hard one time, and pinched the trailer wiring between the rear cross-member and the body (if I'm remembering the spot right). Was getting weird combinations of fuse blowing with turn signal and brakes. Finally figure out that it was occasionally shorting between the harness wires and that the wires had been damaged under the vehicle. Replaced that section of wire and re-routed it more intelligently, and never had a problem since.

    Cheers,
    JFS III
     
  4. JMRINS

    JMRINS

    Messages:
    227
    Likes Received:
    0
    Joined:
    May 12, 2008
    Location:
    Anderson, SC
    It does have a trailer harness, which she's never used, but that could be the root of the problem. I've read on the other tech forums that that usually causes some type of malfunction at some point. Thanks for the help, I'll re-post if I don't track it down this weekend.
     
  5. SeanAndHis80

    SeanAndHis80

    Messages:
    561
    Likes Received:
    4
    Joined:
    Apr 10, 2003
    Location:
    Chester, NH
    Yeah - I had a very similar situation that immediately fixed itself when I took the aftermarket Hoppy trailer wiring harness and adapter out of my electrical system.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.