1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Alarm Malfunction on my 98

Discussion in '100-Series Cruisers' started by nipp, Aug 16, 2006.

  1. nipp

    nipp

    Messages:
    9
    Likes Received:
    0
    Joined:
    Feb 22, 2006
    After unlocking my 98 with the keyless entry it will sometimes kick off the alarm when I open the door. Anyone else have this happen to them? I wouldnt mind disconnecting the alarm if I had to. I know my neighbors are getting tired of it.
     
  2. warren

    warren

    Messages:
    21
    Likes Received:
    0
    Joined:
    Aug 11, 2006
    I just had the same thing happen to me last week. My Keyless entry also would not lock the doors. Check that the key in the door lock unlocks and locks all doors. That was my problem bad contact at the passanger door key tumbler

    Warren
     
  3. marsva

    marsva

    Messages:
    9
    Likes Received:
    0
    Joined:
    Aug 21, 2006
    alarm system problems

    I also have a problem with my 98 alarm system. 165k
    I often leave my keys in the ignition and hardly ever lock the car. Last week, after sitting with the keys in the ignition and several windows open, the alarm went off. It later again went off again with the keys in the ignition and the rear hatch open. I later sneaked back to talk to my mechanic at the Toyota dealer and he was concerned that it might be hard to track when it goes off with the keys in the ignition and that it might be expensive to fix. I would just as soon disconect the system but he stated that it interups the
    ECU starting program if disconnected. In reading the FSM I can find only diognostic help with the key out of the ignition. I parked the
    truck and disconnected the battery. Help!
     
  4. richg

    richg

    Messages:
    183
    Likes Received:
    0
    Joined:
    Nov 16, 2005
    Has this ever been resolved?

    This JUST started happening to my 98 at 165K. I unlock the doors via the remote, the lights flash and the doors unlock as normal without issue, but when I open the door the alarm starts to go off.

    If I then push the unlock button a couple times, the alarm stops sounding and all is fine.

    Rich
     
  5. Kinan

    Kinan

    Messages:
    6
    Likes Received:
    0
    Joined:
    Feb 8, 2008
    Location:
    San Diego
    This might sound from out in left field but when you press the unlock button do all of the doors actually unlock? Maybe one of the doors isn't unlocking so the alarm sees a locked door and a door opening so it thinks glass has been broken and it trips the alarm.
     
  6. Herky

    Herky

    Messages:
    423
    Likes Received:
    0
    Joined:
    Nov 1, 2003
    Location:
    E. Washington
    Same thing has happened to me. did you lock it with the remote or with the switch on the door? On a side note, I can't stand my remote. I think it has a range of about 38". I can't even unlock the rig from the tailgate.
     
  7. richg

    richg

    Messages:
    183
    Likes Received:
    0
    Joined:
    Nov 16, 2005
    I have only locked and unlocked it via the remote. I haven't yet tried with the key or via the switch as it has just started happening.

    The remote key works quite well for me actually. I get about 30-40 ft or so.

    I have not seen if all doors unlock or not. The bizarre thing is, the lights on the truck flash so SOMETHING has registered that it has received the signal to unlock, and successfully unlocks the doors, but for whatever reason, that signal isn't read by the ECM properly to disarm the alarm.

    Past few days, everything has been fine now with no issues. I'm almost wondering if it is a problem with the ECM itself? I'll likely have to break out the wiring diagram and see what the logic is...fun fun fun!

    Rich
     
  8. uHu

    uHu Shamowang

    Messages:
    1,599
    Likes Received:
    149
    Joined:
    Nov 27, 2005
    Location:
    Oslo, Norway
    Could the problem with the alarm going off be another water issue? I.e. water ingress in the ECU.
    Leaking windshield? Moist footwell anyone?

    If the remote has a short range, try changing the battery. My remote keys work at a range of 30-40 too, but not feet or inches, but meters. Only some places, typically in a city street or at a mall, it will reach only 20 feet or so. Suppose because of interference.
     
  9. richg

    richg

    Messages:
    183
    Likes Received:
    0
    Joined:
    Nov 16, 2005
    For me, I don't think its a water issue. It just started doing it during a period when we've had no rain at all. It rained like crazy yesterday all day and the alarm has been fine with no issues whatsoever both yesterday and today.

    There is no evidence of moisture or water either after a rainstorm.

    rich
     
  10. Liam

    Liam

    Messages:
    4,548
    Media:
    31
    Albums:
    4
    Likes Received:
    8
    Joined:
    Feb 10, 2005
    Location:
    in the nappy dugout
    now that sucks........good luck
     
  11. CoolBreeze

    CoolBreeze

    Messages:
    27
    Likes Received:
    2
    Joined:
    Nov 21, 2008
    Location:
    East Bay, CA
    Rich, did you ever fix your alarm problem? My 98 LX is behavely exactly as yours was. It does it about 4 times a week now. It's getting annoying. Just looking for some pointers. Thanks.
     
  12. steenh

    steenh

    Messages:
    2,247
    Likes Received:
    717
    Joined:
    Jul 12, 2006
    Location:
    Alpharetta, GA
    Had the same issue on mine. Ended up switching out the fuse box on the drivers side. No issue since, but not an easy fix. Mechanic told me he's seen it before on occasion.
     
  13. NMuzj100

    NMuzj100

    Messages:
    3,480
    Likes Received:
    26
    Joined:
    Sep 25, 2004
    Location:
    Gleneagle, CO
  14. richg

    richg

    Messages:
    183
    Likes Received:
    0
    Joined:
    Nov 16, 2005
    Nope, never did.

    What I found works for me is if I unlock both drivers and passenger doors AND I wait for the lights to stop flashing, the alarm won't go off. If I'm quick on the draw and try to open the door just after it is unlocked, the alarm goes off. Or sometimes if I just unlock the driver's door, it will go off.

    I haven't bothered to start tracing wiring diagrams to guess at what is sending a bad signal.

    Sorry I can't be of more help.

    rich
     
  15. richg

    richg

    Messages:
    183
    Likes Received:
    0
    Joined:
    Nov 16, 2005
    Wanted to close the loop on this thread.

    My alarm problem ended up being due to a weak drivers door lock actuator. Occasionally, even though the actuator had physically unlocked the door, the signal to the ECU wasn't getting sent that the door was indeed unlocked (even though the ECM registered that it had received the unlock signal via the remote). Since replacing the actuator, haven't had the problem again.

    rich
     
  16. CoolBreeze

    CoolBreeze

    Messages:
    27
    Likes Received:
    2
    Joined:
    Nov 21, 2008
    Location:
    East Bay, CA
    Rich, thanks for updating us. I posted in this thread 2.5 years ago, but found no fix yet, and it is the single biggest issue I'm having with this truck. I'm tired of waiting 5 seconds to open my door.

    How did you determine that it was the driver's door lock actuator? Did you only replace the one in that door, or all of them?

    Thanks!
     
  17. richg

    richg

    Messages:
    183
    Likes Received:
    0
    Joined:
    Nov 16, 2005
    Sorry, just saw the reply back now while searching for other things,

    All of a sudden one day noticed that when the remote unlock button was hit, the visual indicator on the driver's door lock wasn't showing it as being opened. So I opened the door manually and then played with the power lock buttons and sure enough, the motor was getting weak.

    It had never indicated that there was a problem before when I tested things previously, so I'm not sure how you'd be able to tell which actuator is going bad.

    rich
     
  18. prerunner84

    prerunner84

    Messages:
    273
    Albums:
    2
    Likes Received:
    1
    Joined:
    Nov 6, 2011
    I'm having this problem with my 99 it's the only thing I can't stand about my truck
     
  19. kramermic

    kramermic

    Messages:
    54
    Media:
    1
    Likes Received:
    4
    Joined:
    Dec 21, 2008
    I'm having this problem right now on my 98. This is the only thread I've found that is exactly my problem. I will unlock the car with the remote and everything will physically unlock (most of the time). Two things I've noticed: the driver's door actuator and the rear hatch actuator seem like they are getting weak but... if I am in the car with it running and lock / unlock the car more than a few times in a row all of the locks begin to start moving slowly and then stop moving period. If I wait a few minutes, they will begin to work properly and then shut down slowly if I move the switch multiple times again. This has started making me think it may be an issue in the master switch / module for the door locks. Has anybody resolve this issue yet?
     
  20. Dwight S

    Dwight S

    Messages:
    769
    Likes Received:
    350
    Joined:
    Mar 27, 2012
    Location:
    Garner, NC
    I'm going to say to replace the actuators and see if that doesn't resolve the issue. I believe the locks and alarm are tied together so when the locks only partially move and you open the door, the alarm is triggered.
     
data-matched-content-rows-num="2,1" data-matched-content-columns-num="1,4" data-matched-content-ui-type="image_stacked" data-ad-format="autorelaxed">