1hdt water/fuel sensor

Joined
Aug 26, 2017
Messages
257
Location
Fort Polk, LA
Visit site
Hey everyone,

Sorry if this has been discussed before. I’m just trying to help out the boys in the states who may run into a similar issue and don’t want to or can’t wait for items to arrive from overseas.

I recently replaced my fuel filter and during the process the wires to the water in fuel sensor broke. The wires were super brittle and I didn’t do a good job making sure the wires weren’t twisting as I was removing the filter.

I attempted to solder the wires back on, but there was very little wire left to solder to. The solder job was kind of successful, but after putting it all back together it wouldn’t hold steady fuel pressure. After a few pumps of the primer, fuel would start leaking from the sensor. I triple checked that the drain cock(haha) was tight, the sensor, and the filter itself. I used the new oem o ring that was included.

I ordered a new sensor from Mcgeorge toyota. They contacted me and said that I needed to send them a vin number to confirm fitment. I told them that last time I sent them a vin number they didn’t have my vin in their records. They claimed the part isn’t stocked in the US, but why would they have the part number in their system and allow me to order it? Regardless. I cancelled the order and looked elsewhere.

I was talking to my soon to be father in law about the fuel leak and after looking at some parts together, we learned that his 2012 duramax uses the same filter and sensor. Well I ordered a new sensor from amazon for 20 bucks. It was a whole lot cheaper and quicker shipping than overseas. I tried to de pin the wires from both sensors, but I was unsuccessful because I was using a little pick out of a weapons cleaning kit I have. I got impatient so I just cut the wires off and used heat shrink solder connectors to attach the toyota plug to the gm sensor.

With the leaky sensor the truck didn’t idle right, would stall out, and wouldn’t start without giving it a little throttle. Now it cranks and turns over in a split second as it did before. I try to buy oem parts, but sometimes it’s such a hassle. Hope this helps someone out there.

D856A458-30EB-4B7B-A9B2-656C18E9E1BF.jpeg


F2320714-0D36-4D2E-96F1-460C2490D59F.jpeg


BDFC7654-7A5B-4323-A5E8-8A289EF55EC1.jpeg


73B88689-7370-40BC-8CAF-7B9CCC14C02E.jpeg
 
Joined
Sep 30, 2014
Messages
569
Visit site
Hey mate, great tip... thanks for sharing. I reckon there are a lot of compatible parts from other vehicles we could use, just sometimes hard to find/figure out.
 
Joined
Aug 8, 2015
Messages
689
Location
Somewhere
Visit site
Do you guys have the part number for the connector itself which plugs to the sensor ? I would like to wire this up after 1hdfte conversion to some not used light in the dashboard . The 1hdft/fte has the same sensor and connector .
Thanks
 

Users who are viewing this thread

Top Bottom