1987 fj60 electrical issue

Joined
Oct 30, 2007
Messages
10,416
Location
Plano texas
Hi, Buzzing under dash by fuse panel when, Blower is turned on ; or lights are turned on. No buzzing when running lights are on or car is turned on To start and it’s running. Thoughts? Thanks, Mike
 

OSS

SILVER Star
Joined
Jun 30, 2017
Messages
4,896
Location
Oblivion
Its one of the relays with either a bad connection or on its way out.
There’s a cluster of them plugged into a board under the dash. Put your head on the floor & look up w a flashlight. Youll see them.
Set the car accessories so it buzzes then get under there and touch different relays. You’ll soon find the offender.
 
Joined
Oct 30, 2007
Messages
10,416
Location
Plano texas
That’s what I thought too. Replaced all but the heater one, waiting for it to come in. Will know tomorrow if that’s it.
 
Joined
Oct 30, 2007
Messages
10,416
Location
Plano texas
Heater blower replaced still buzzing. No head lights at all. Thinking now turn ,light stalk on column.
 

micruz60

Unleaded Regular
Joined
Nov 6, 2006
Messages
1,814
Location
East of the Crossroads
It's amazing how dirty / futzy the interior of the clamshell on the steering column gets.
Probably a bit of oxide on the contacts, horn pin still working?
 
Joined
Oct 30, 2007
Messages
10,416
Location
Plano texas
Why does everything go out at once. Working on 4 cruiser and the brake master cylinder in the Ram died yesterday.Replacing it now. My goodness to bench press the master in it took half an hour to get the air out. I have several column switches I will be pulling apart to see what’s wrong with them and try to get one working.I think the 1987 and fj62s use the same column switch.
 
Joined
Oct 30, 2007
Messages
10,416
Location
Plano texas
Well after a complete brake job new calipers etc on the Ram. Starting in on the 1987 fj60 again this weekend.So far nothing all fuses appear good.
 

Users who are viewing this thread

Top Bottom