Where did my HC clips go??

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, Skimlinks, and others.

Joined
Sep 14, 2013
Threads
13
Messages
136
Location
Mount Pearl, Newfoundland
Hey folks. Was wondering if I could get a bit of help. I just got this FJ40 and after spending a lot of time on this forum I beleive I have stock rims on it. The weird thing is it seems the PO removed the hubcap clips??? :frown: Question is, can you buy these clips after market? If so does anyone know how to get the clips back on the rims? :confused: I think they are already marked where the scratched paint is...:D

Or do I have to buy new rims??:mad:

I'd really like to run stock rims with the dresser caps. Ive never seen them on a 40 around my neck of the woods and I think it looks deadly!

Thanks folks...
image (3).jpeg
image.jpeg
 
Those may be early 4x4 pickup stock rims. My 86 base 4x4 had white rims that did not have clips.
 
The wheels came with clips and without clips those look oem for sure I just sold a set without clips

Sent from iPhone :cheers:

Thanks looks like I got the cheap kind without the clips....

This has been discussed several times:

https://forum.ih8mud.com/40-55-series-tech/221665-homemade-hubcap-clip-wheels.html

It looks like it would be alot easier to get a set of rims with clips.

Thanks for the link, I think you're right. Sounds like a massive pain in the arse to install clips. Guess I'm in the market for some rims and tires. Bollucks!!
 

Users who are viewing this thread

Back
Top Bottom