What's up with my brights.....electrical or do I just need new bulbs?

Joined
Aug 25, 2006
Messages
139
Location
Down by the River
Visit site
So the past two nights when I have tried to turn my brights on either thay haven't come on at all, and I've clicked them a few more times until they do come, or they come on after a few seconds. They've never done this before and I am wondering if it is an electrical issue or if I just need to lights?

Thanks,
Rowan
 
Joined
Aug 25, 2006
Messages
139
Location
Down by the River
Visit site
No click from under the dash.....they are the brights not the headlights - the headlights work fine. It happened one night and then didn't happen the next night - and I haven't really driven it anywhere since then.
 

rchalmers3

I speak Toyota
Joined
Jun 29, 2007
Messages
1,539
Location
Playas de Nosara, Nicoya Peninsula, Costa Rica
Visit site
I'm gonna guess it's just some lint or dust munging up the contacts on the dimmer switch. Toying with the dimmer switch when it's failing should give you some insight into where the failure is.

Cleaning the contacts with electrical contact spray will prolly give you reliable service.

Best wishes with eliminating the intermittant problem.

Rick
 
Joined
Jun 7, 2003
Messages
207
Location
Manitoba, Canada
Visit site
I've got the same problem on mine. Started acting up in the fall just before I took it off the road before winter.

I'm thinking if I'm gonna be farting around a whole bunch to get them working, I might as well put in a new wiring harness and even perhaps a new control circuit for the high output lights.
 

Users who are viewing this thread

Top Bottom