What Did You Do with Your 80 This Weekend? (45 Viewers)

Joined
Dec 26, 2012
Messages
1,123
Location
Minneapolis, Mn
This is proof you don’t need a brodozer to have a capable truck!
Agreed..that's my ethos. Keep it as light as possible and only add things AFTER you realize you need them because out of the box the 80 is more than capable for 99% of the things people actually do.

PXL_20220901_013410859.MP.jpg


PXL_20220903_175754844.jpg


PXL_20220904_203308659.MP (1).jpg
 

Rouleur

GOLD Star
Joined
Oct 7, 2020
Messages
375
Location
Seabrook Texas
Last edited:

surfpig

The Anti-Tech
Joined
Jan 14, 2005
Messages
5,360
Location
Here. Now.
Yes if you leave the old one in place it’s a ten minute job. If not you can get that sucker out it’s just a PIA. I just loosen the intake plenum bracket and move it to the side then reach under there and undo the two hoses I capped both the intake pass thru hoses with screws and a piece of vacuum hose. Then attach longer hose to there perspective ports and zip tie in place. Grab the connector and hook it up. Then step 6 🍻
Well the P0401 code randomly went away yesterday (on since April!). So I guess I'm good!

:hillbilly:
 
Joined
Nov 9, 2012
Messages
13,508
Location
Olathe, KS, USA

surfpig

The Anti-Tech
Joined
Jan 14, 2005
Messages
5,360
Location
Here. Now.
Well the P0401 code randomly went away yesterday (on since April!). So I guess I'm good!

:hillbilly:
@TYM4FUN remember when I was having weird gas tank pressure issues along with the P0401 last April? Both of those switching valves sit there cooking under the manifold…
 
Joined
Nov 16, 2019
Messages
198
Location
Southaven, MS
Installed one on my speakers today, hope to finish up this week.. had to surface mount, but they fit.. just barely though. These are the Kicker 47KSS6504 components that can also run as coaxial mount. Plan to move the tweeter up high once I purchase the amplifier..

A1B8A23E-B5D5-46D3-93FF-C1A9835882F3.jpeg


AD60DB91-B7A4-4553-9711-8D4D8DC6A445.jpeg


9FBD5289-2A43-4FFC-B1F2-4E4DC1CE72C4.jpeg
 
Joined
Jan 6, 2008
Messages
74
Location
Taft, TN
Been working for a few weeks to get some factory wheels. Picked up a set with about 32 different layers of paint on them. Bead blasted them then 3 coats of white and 3 coats of clear. Then got some new shoes for them. Cooper Discovery STT Pro 315/75/16. I'm pretty happy how they turned out.

IMG_20221106_154156912_HDR.jpg


IMG_20221106_154103250.jpg
 
Joined
Feb 24, 2016
Messages
490
Location
Oviedo, FL
Joined
Nov 16, 2019
Messages
198
Location
Southaven, MS
What do you mean by surface mount? Report back with how they sound when you're done!
Probably a poor choice of words, but I mounted the woofer on the outside of the door card instead of behind the door card. When I mounted behind the door card, between the needed spacer and the woofer, there was too much of a bulge of the door card for my taste. I really wanted to avoid trimming the door card, but may do so at a later date..

Thanks,
dg
 

Somebodyelse5

Enginerdin'
Joined
Feb 9, 2014
Messages
3,785
Location
Tukee Town, AZ
Nice rigs. Looks nice and warm there.

Yup, it’s the best time of year here. Lows in the 40’s!

But don’t tell anyone… we want people to stop moving here
 
Joined
May 14, 2022
Messages
409
Location
Egypt
Cleaned the air control sensor in an attempt to improve efficiency and sort out the unburned exhaust coming out.
I need to change some of the gears in the KM counter in the dashboard, its not working properly.

Removed the center cover with the gears, added some extra wire for length, replaced the 12 Volt with a new one and removed access old cables.

I have noticed a little blue exhaust coming out so seems like I need to rebuild engine (that with low oil pressure and worn piston bearings as well.)

Got 2 new back LED lights for covering behind the car have not installed them yet.

I did not take any pictures this time :S
 
Joined
Jan 19, 2005
Messages
3,768
Location
South west utah
@leonard_nemoy ok. I got old cable off and out and put up against new cable.

Old cable has metal and plastic holders that appear were either crimped on or cable was slid thru them. Also has heat shield wrap toward T case and heavier wrap where it come thru floor board in front of shifter and goes thru a grommet. Grommet also had cable slid thru it appears before one end was attached. So I carefully slit with a razor and plan to glue seam back.

Any advice on using existing holders, replacements that I can crimp on, wrap, etc.

View attachment 3160782

View attachment 3160783

View attachment 3160784

View attachment 3160785

View attachment 3160787

Sorry man buy you got further than I ever did. On my old 91 I got the cable removed, cleaned it and re-installed because I couldn't find a replacement.

I suggest posting a dedicated thread to this topic and maybe someone will have some experience and good advice for you.

My only other tip would be to clean and lube your replacement cable before you install it.
 
Joined
Jan 19, 2005
Messages
3,768
Location
South west utah
Towed my buddy and his boat to the lake for some fishing.

20221106_103723.jpg
 

Users who are viewing this thread

Top Bottom