1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Weber Issues

Discussion in '60-Series Wagons' started by RedfishBluegrass, Jun 28, 2005.

  1. RedfishBluegrass

    RedfishBluegrass

    Messages:
    551
    Albums:
    1
    Likes Received:
    1
    Joined:
    Apr 21, 2005
    Location:
    Charleston, SC
    This being my last week at my current job I am trying to get the 60 up to DD specs becasue I have to return my work truck and it is not going well. I have replaced all belts, adjusted clutch, fixed guages and when I thought she was ready I looked and found a gigantic fuel leak. My lines were rotten so I bought some new ones. On the install I realized that my 38 Weber was not bolted down tight at all. It shifts around on the seat. There appers to be just four bolts to tighten...Is that it? Also, I noticed that the fuel line is connected to what looks to me like a regulator (not bolted to the carb) and then goes to the carb. Does anyone know what this seperate piece is? Do I need it, or can I just take it out of the loop? Thanks.
     
  2. treerootCO

    treerootCO Where are my keys?! SILVER Star

    Messages:
    3,752
    Likes Received:
    697
    Joined:
    Jun 2, 2004
    Location:
    Wheat Ridge CO
    Could be a regulator....you can run without a regulator. Make sure it isn't your fuel filter.

    Most Weber adapters have 1 plate bolted to the manifold, then the studs that hold down the carb. Find both and tighten both. I found that most of the bolts that tighten the adapter to the manifold are too long. Make sure you can tighten the bolts without them hitting bottom.
     
  3. wingysataday

    wingysataday

    Messages:
    789
    Media:
    1
    Likes Received:
    168
    Joined:
    May 16, 2005
    Location:
    Boise
    what is your carb jetted at? How do you adjust the fuel/air mixture.
     
  4. RedfishBluegrass

    RedfishBluegrass

    Messages:
    551
    Albums:
    1
    Likes Received:
    1
    Joined:
    Apr 21, 2005
    Location:
    Charleston, SC
    Okay, lastnight I unbolted the whole damn thing and found that it was the bottom adapter plate that bolts to the manifold that was loose. Now it is all put back together and seems to be fine except when I rev it really high. It is smoking out of the K&N filter on top and seems to be hissing like it is getting too much fuel. The idle is alright, maybe a little low. Any ideas what in the hell the smoke is all about? I don't know what it is jetted at, but it does have two adjusting screws, one on either side. Still not sure if that extra piece is a regulator or not. Thanks for the input.
     
  5. wingysataday

    wingysataday

    Messages:
    789
    Media:
    1
    Likes Received:
    168
    Joined:
    May 16, 2005
    Location:
    Boise
    could be the oil burning off the filter.
     
  6. beaner

    beaner

    Messages:
    13
    Likes Received:
    0
    Joined:
    May 27, 2005
    Location:
    keene, tx
    does that extra piece have a knob on top? if so, it's your fuel pressure regulator. the smoke might actually be an exhaust leak at your manifold.
     
  7. RedfishBluegrass

    RedfishBluegrass

    Messages:
    551
    Albums:
    1
    Likes Received:
    1
    Joined:
    Apr 21, 2005
    Location:
    Charleston, SC
    Thanks for the help guys. It was a regulator with the knob on top. I had a professional adjust it yesterday and she is purring like a cat.
     
  8. beaufort-fj60

    beaufort-fj60

    Messages:
    4,508
    Media:
    10
    Albums:
    1
    Likes Received:
    7
    Joined:
    Feb 5, 2005

    who did you take it to?
     
  9. RedfishBluegrass

    RedfishBluegrass

    Messages:
    551
    Albums:
    1
    Likes Received:
    1
    Joined:
    Apr 21, 2005
    Location:
    Charleston, SC
    A friend of the family who has installed a thousand webers and believe it or not works at a Precision Tune in Charleston. He is awesome. It took him about five minutes to adjust everything. It limped in the shop boggging down and it came out running smoother than ever.
     
  10. beaufort-fj60

    beaufort-fj60

    Messages:
    4,508
    Media:
    10
    Albums:
    1
    Likes Received:
    7
    Joined:
    Feb 5, 2005
    precision tune in west ashley (base of bridge comming out of down town / accross from fishing store)
     
  11. RedfishBluegrass

    RedfishBluegrass

    Messages:
    551
    Albums:
    1
    Likes Received:
    1
    Joined:
    Apr 21, 2005
    Location:
    Charleston, SC
    Thats the one. The fellas name is Richard. He is also going to tackle my clutch here shortly. We are taking our annual fishing trip to Pritchards Island at the end of July, any news on the fishing down there?
     
  12. beaufort-fj60

    beaufort-fj60

    Messages:
    4,508
    Media:
    10
    Albums:
    1
    Likes Received:
    7
    Joined:
    Feb 5, 2005
    talked to a guy yesterday said he got two cobia last weeks off shore on artificial reef. said that was the only two hits he had all day. I have not set foot in my boat in about 6 weeks, so I have not caught s***.

    I have heard good things about that precision tune before.


    just wondering? is that andy g. holding the fish in you avitar?
     
  13. RedfishBluegrass

    RedfishBluegrass

    Messages:
    551
    Albums:
    1
    Likes Received:
    1
    Joined:
    Apr 21, 2005
    Location:
    Charleston, SC